ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      02-14-2012, 07:38 PM   #45
gferil
Captain
 
gferil's Avatar
 
Drives: 06 Z4MC
Join Date: Dec 2010
Location: San Francisco, CA

Posts: 731
iTrader: (5)

I also have the UUC Option 1's (ordered in November, shipped in Jan) without the enforcer cups (actually I ordered those but after reading this helpful thread I decided not to install them, thanks Finnegan!), and I LOVE how they have improved the feel of the transmission. Also, the NVH that it added is awesome, totally brings a very "raw" sound to the car above 4K, but is still civil enough to be used as a daily driver, and when you combine it with the GruppeM intake I have...it's pure awesome-ness...if that's even a word.
gferil is offline  
0
Reply With Quote
      02-14-2012, 08:32 PM   #46
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

Excellent!

This is one of those mods that 99% of folks agree on. The stock mounts are marshmallows, and really are inadequate to the HP/TQ of any of the inline 6s offered. Where you go from there is just a matter of desired effect and intended application.
Finnegan is offline   United_States
0
Reply With Quote
      02-14-2012, 10:00 PM   #47
Shipkiller
Lieutenant Colonel
 
Shipkiller's Avatar
 
Drives: Me
Join Date: Oct 2007
Location: Virginia Beach

Posts: 1,973
iTrader: (3)

Garage List
Poly
__________________
.
.
You never have enough time to do the job properly the first time, but you always seem to have the time to do the job a second time....
Shipkiller is online now   United_States
0
Reply With Quote
      03-04-2012, 09:18 PM   #48
ZooyorQ
Private First Class
 
Drives: BMW M3
Join Date: Sep 2010
Location: Bay Area

Posts: 140
iTrader: (0)

Anyone running solid motor and tranny mounts?
__________________

849rwhp/629rwtq - 10.56@142.7 - 5.6s 60-130 on street tires on 19x10" wheels - manual 6spd
ZooyorQ is offline  
0
Reply With Quote
      03-04-2012, 09:21 PM   #49
inTgr8r
Major General
 
inTgr8r's Avatar
 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

Posts: 7,830
iTrader: (7)

Unless it's a 100% dedicated track beast, why would you want to?
__________________
Alpinweiss '07 M Coupe •DKF Section1•Eisenmann Sport-Ceramic Black•Fabspeed Headers•VRS Hyper-Narrow rear wing•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•KW Clubsport•H&R ARBs c/w Turner Adj Links•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
inTgr8r is offline   Canada
0
Reply With Quote
      05-22-2012, 12:01 AM   #50
jophish17
First Lieutenant
 
jophish17's Avatar
 
Drives: Z4MC
Join Date: Jun 2011
Location: Decatur, GA

Posts: 345
iTrader: (0)

Garage List
2012 BMW 328  [0.00]
2007 BMW Z4M  [5.00]
Local Shop has these mounts from AKG - given the price, I'm assuming they are similar to Rogue mounts in terms of being ok for street driving - am I assuming too much? Should I just order the Rogue's? Thanks in advance
jophish17 is offline   United_States
0
Reply With Quote
      05-22-2012, 12:17 AM   #51
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

Quote:
Originally Posted by jophish17 View Post
Local Shop has these mounts from AKG - given the price, I'm assuming they are similar to Rogue mounts in terms of being ok for street driving - am I assuming too much? Should I just order the Rogue's? Thanks in advance
Those are poly mounts. And will have significant NVH. Unless this is a track car, I'd go with Rogue Neoprene.
Finnegan is offline   United_States
0
Reply With Quote
      05-22-2012, 12:19 AM   #52
jophish17
First Lieutenant
 
jophish17's Avatar
 
Drives: Z4MC
Join Date: Jun 2011
Location: Decatur, GA

Posts: 345
iTrader: (0)

Garage List
2012 BMW 328  [0.00]
2007 BMW Z4M  [5.00]
I guess had I read the whole page I could have seen that - thanks for pointing that out
jophish17 is offline   United_States
0
Reply With Quote
      05-22-2012, 01:17 AM   #53
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

Quote:
Originally Posted by jophish17 View Post
I guess had I read the whole page I could have seen that - thanks for pointing that out
Yeah, but I'm long-winded (or shall we say "complete") at times. Don't mind the question, don't mind answering either.
Finnegan is offline   United_States
0
Reply With Quote
      07-02-2012, 02:42 AM   #54
SmartBastard
Stupid as shit
 
SmartBastard's Avatar
 
Drives: '08 M Coupe
Join Date: Jan 2011
Location: Vienna, Austria

Posts: 364
iTrader: (0)

Question

Hey guys, I need an advice.

I was on a track day this Saturday, pushing the car pretty hard and unfortunately missed the shift from 3rd (@8000 rpm) to 4th twice during the day and got the grind noise. I wasn't pushing it in too hard so I just let it go back to neutral, pushed the clutch fully in again and put 4th in.

After the track day we had some street racing with 2 other guys (don't ask) and I noticed vibration noise @ 7000 rpm and higher. First I though it was smth in the glovebox at a weird frequency, but then I wanted to shift and I noticed bigger vibration in the gear stick and that it's the stick which is doing the noise (when I pushed the stick it just a lil bit down, it got louder).

The question is, are the transmission mounts weared out or did I mess up my gearbox? :-/

I tried it again later and the vibration wasn't that bad and a day after it was actually almost gone, but I still know that there's smth wrong and want to fix it. Thanks for any advice!
SmartBastard is offline   Austria
0
Reply With Quote
      07-02-2012, 10:35 AM   #55
RobMCoupe
Captain
 
RobMCoupe's Avatar
 
Drives: 2007 Z4 M Coupe
Join Date: Feb 2010
Location: Bay Area

Posts: 684
iTrader: (4)

Quote:
Originally Posted by SmartBastard
Hey guys, I need an advice.

I was on a track day this Saturday, pushing the car pretty hard and unfortunately missed the shift from 3rd (@8000 rpm) to 4th twice during the day and got the grind noise. I wasn't pushing it in too hard so I just let it go back to neutral, pushed the clutch fully in again and put 4th in.

After the track day we had some street racing with 2 other guys (don't ask) and I noticed vibration noise @ 7000 rpm and higher. First I though it was smth in the glovebox at a weird frequency, but then I wanted to shift and I noticed bigger vibration in the gear stick and that it's the stick which is doing the noise (when I pushed the stick it just a lil bit down, it got louder).

The question is, are the transmission mounts weared out or did I mess up my gearbox? :-/

I tried it again later and the vibration wasn't that bad and a day after it was actually almost gone, but I still know that there's smth wrong and want to fix it. Thanks for any advice!
Dud you replace engine mount bolts?
RobMCoupe is offline  
0
Reply With Quote
      07-02-2012, 02:23 PM   #56
SmartBastard
Stupid as shit
 
SmartBastard's Avatar
 
Drives: '08 M Coupe
Join Date: Jan 2011
Location: Vienna, Austria

Posts: 364
iTrader: (0)

Quote:
Originally Posted by RobMCoupe View Post
Dud you replace engine mount bolts?
No, the whole car is pretty much stock, except for AP racing kit and APEX wheels.
SmartBastard is offline   Austria
0
Reply With Quote
      07-02-2012, 03:00 PM   #57
RobMCoupe
Captain
 
RobMCoupe's Avatar
 
Drives: 2007 Z4 M Coupe
Join Date: Feb 2010
Location: Bay Area

Posts: 684
iTrader: (4)

Quote:
Originally Posted by SmartBastard
Quote:
Originally Posted by RobMCoupe View Post
Dud you replace engine mount bolts?
No, the whole car is pretty much stock, except for AP racing kit and APEX wheels.
My car had vibration when the bolts cracked. It was after replacing aftermarket tranny mounts.

Do a search for the thread. You'll see the engine dropped on the passenger side.
RobMCoupe is offline  
0
Reply With Quote
      07-03-2012, 02:56 AM   #58
SmartBastard
Stupid as shit
 
SmartBastard's Avatar
 
Drives: '08 M Coupe
Join Date: Jan 2011
Location: Vienna, Austria

Posts: 364
iTrader: (0)

Thumbs up

Quote:
Originally Posted by RobMCoupe View Post
My car had vibration when the bolts cracked. It was after replacing aftermarket tranny mounts.

Do a search for the thread. You'll see the engine dropped on the passenger side.
Thanks a lot, I'll look into this!

http://www.zpost.com/forums/showthread.php?t=635649

Last edited by SmartBastard; 07-03-2012 at 03:05 AM.
SmartBastard is offline   Austria
0
Reply With Quote
      07-21-2012, 05:50 PM   #59
zubydafa
tosser
 
Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

Posts: 988
iTrader: (0)

What do you guys think of the UUC red isolated urethane engine mounts?

UUC site recommends them with the option 2 red urethane isolated tranny mounts.
__________________
'07 MCoupe
lots of mods
zubydafa is offline   Isle of Man
0
Reply With Quote
      07-22-2012, 09:09 AM   #60
zubydafa
tosser
 
Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

Posts: 988
iTrader: (0)

sorry...one more question.

i could do UUC red isolated urethane engine and tranny mounts for $260 total
215 for the engine mounts
45 for the tranny mounts

or i could do Vorshlag red 95 urethane engine and tranny mounts for $278 total
189 for the engine mounts
89 for the tranny mounts

opinions/suggestions por favor?
__________________
'07 MCoupe
lots of mods
zubydafa is offline   Isle of Man
0
Reply With Quote
      07-22-2012, 02:55 PM   #61
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

There's a thread by someone who installed red poly engine mounts (can't find it, on mobile). Look at that--lots there.

Not aware of any marked diffs between poly. Isolated or bolt through though, that will make a big diff (bolt through will rattle your teeth out). Check the design specs, not just the materials.

With isolated poly in both engine and transmission you'll get a lot more NVH than stock or neoprene. Not an issue if you know that going in.

Give update when done. Thanks.
Finnegan is offline   United_States
0
Reply With Quote
      09-02-2012, 08:56 PM   #62
Spreadsheet
Enlisted Member
 
Drives: Black 2007 Z4MC
Join Date: Feb 2009
Location: Oklahoma City, OK

Posts: 47
iTrader: (0)

Just installed Rogue Engineering Performance Engine Mounts and Transmission mounts. As advertised, lots of increase NVH. But it is just at idle, once underway and above 1K RPM, I don't notice it one bit. But at idle, there is a ton of NVH compared to stock, so be ready.

Also installed UUC short shift kit and Vershlag camber kits with AST coilovers at the same time, so all NVH increased, but livable by my terms.

Totally different vehicle with the mods, I'm loving it!
Spreadsheet is offline   United_States
0
Reply With Quote
      09-03-2012, 02:04 AM   #63
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

It's great to have some feedback on the engine mounts. Thanks.
Finnegan is offline   United_States
0
Reply With Quote
      12-22-2012, 06:05 PM   #64
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,244
iTrader: (17)

Original post updated to reflect info on Vibra Technics and cross members. More will be added as data comes in.
Finnegan is offline   United_States
0
Reply With Quote
      01-13-2013, 11:48 AM   #65
Spreadsheet
Enlisted Member
 
Drives: Black 2007 Z4MC
Join Date: Feb 2009
Location: Oklahoma City, OK

Posts: 47
iTrader: (0)

Here's an update as have been living with these mods for over 4 months now. Only drawback to the stiffer mounts is the buzz at idle, when at a longer stoplight I just push the throttle to about 1,000 RPM and all is buttery smooth. Asked my non-dealer mechanic if could raise my idle to 1,000 RPM, was told not possible. Dealer tells me maybe, will see at next service interval in about a month. At 1K or more no buzz or shake, very noticable at stock idle speed.

Suspension is great, I wouldn't change a thing with either modification. Ride is as good or better than stock except over sharp edges. Car turns on a dime and offers a dollar in change. Really loving the square setup, maybe should have gone with the 265s instead of the 245, but not beating myself up over it for a street setup. I didn't think I needed them, but now believe I will add upgraded sway bars from Ground Control. Car is handling well, but think this will take it up another notch.

Can't wait to start upgrades in the engine compartment!
Spreadsheet is offline   United_States
0
Reply With Quote
      04-08-2013, 04:10 AM   #66
007MCoupe
Major
 
007MCoupe's Avatar
 
Drives: das Bierwagen
Join Date: Jun 2010
Location: the 'Ring

Posts: 1,439
iTrader: (4)

Garage List
2007 Z4 M Coupe  [0.00]
I posted this review on AKG Engine and Transmission mounts both, but I did have just the trans mounts on by themselves for a night.

As stated in that thread, these mounts in combination with OEM engine mounts are a terrible idea. And my engine mounts weren't bad at all in terms of wear and tear. NVH was insane. If I were only putting trans mounts on, I would've instantly bought something else. Sorry AKG for the bad words, but it's not a good idea in my experience.
__________________
GoMiniGo///VB3///75mm wheel studs///Stubby///GC front ARB///Pin pulled///Turner Camber Shims///Superflex FCAB///AKG Engine Mounts///AKG Trans Mounts///SS brake lines

H2R, LVMS, Ring...
007MCoupe is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:15 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST