ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > BMW Z4 Photos, Photoshops, Videos and other Media
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      03-17-2014, 08:37 PM   #1
Jimswift
Private
Canada
5
Rep
50
Posts

Drives: 2006 Z4MR
Join Date: Mar 2011
Location: Vancouver, Canada

iTrader: (2)

Jimswift's Z4M Roadster

Alright,

I figured it was time to start a thread for my car. Apologies if this thread gets a bit personal for some of you. I recommend skipping down to the ďContinue HereĒ if thatís your preference.

I first started thinking about purchasing a Z4 about 5 years ago. The CDN dollar was strong against the USD and importing a car made a lot of sense. When I was back visiting family, I told my mom about my plan (she always had a soft spot for cars) and showed her a few photos of the Z4. One year later I received a phone call from my mother, at a dealership mid-purchase to ask me to double-check that the deal she was getting was fair. She purchased her very own silver Z4 3.0i roadster that day, and drove it out to Vancouver a week later to show it off. It was a beautiful car, excellent condition. For the next year I enjoyed reading the odd text message about my mother off having fun in the car with her friends and zipping around town. I was proud of her for finally doing something that was just for her. When winter came, she gave me a call and spoke about how much she was dreading the lot wait until she could get the car back out there.

One month later, my mother passed away of a sudden stroke. She was 61, in excellent health and had a physical from her doctor only a few months before with no concerns. I was shocked, the family was shocked. Life stopped for a little while. Come spring, my stepdad passed me the keys and told me that she would have wanted me to have the car. I drove the car for about one week and decided that I couldnít keep it. While it was a wonderful car and driving it was a great way to remember my mother, I was constantly in fear that someone would damage her car. If someone were to smash the window I would have taken it personally. I made up my mind to trade in her Z4 and purchase my own Z4 (M). That way Iíd have a car that brings me all the good memories but it would be my own, to do with as I pleased. I learned from her the value in living each day and not putting off what matters to another day.




Continue Here

I bought my 2006 z4m three years ago now at roughly 3000 miles and have been enjoying it since, but always with the plan of modifying a few things. After years of researching, months of purchases and what feels like the longest Vancouver ďwinterĒ ever, the car is out of storage and the shop.

Previous changes
- Installed stubby antenna
- Installed the LeatherZ arm rest
- Replaced stock tires 14,000 miles with Michelin PSS

Since owning the car Iíve done a minor paint correction to remove the light scratches left from the previous owner.


Back when she was stock


Mods
- Euro headers coated (matte black)
- DKF sec 1 w/ 300 cell cat
- RPI scoop
- Gruppe M intake
- Stock Mufflers

- KW V3 coilovers

Alright, so here's my review
The KW V3s feel good and inspire confidence. Combined with the PSS, ride quality is generally better than stock, though it does feel a little stiffer than the stock suspension with PSS rubber. In the corners itís a night/day difference. Looks better too (IMO).

The change in sound is amazing. I expected some good intake noise, but I was honestly blown away. With the stock mufflers, the car sounds only a little different when light on the throttle, but putting your foot down transforms the car. Originally I was planning on purchasing an aftermarket muffler but after hearing it as-is, I'm not sure itís required. Very happy with the sound.

Power Increase? I haven't done any dyno sessions and I've only put a few hundred miles on the car since getting it back. So far, not a big difference. If anything, I'd say that below 2500 RPM the car feels a bit slower, and above 5000 feels a bit quicker but its probably just the increased noise that makes it feel that way. I'll wait and see how the ECU continues to adapt.

The bad news. After about 50 miles, the SES light came on. I spoke with the shop and they were fairly confident that the new cat wasn't doing enough. I explained that it was tested on another Z4M before without throwing the SES. They reset the light and told me to drive it hard for the next few weeks to see if maybe the cat just needed to get really hot first and settle in. This seemed like it was working, but after ~150 miles, the light is now back on. Sounds like the next step will be getting a tune, which maybe isn't the worst plan anyways. Just wasn't what I was hoping for.

For those that might get headers coated (which I think was totally worth it) be aware that the first few drives are going to smell. The smell does go away though! I was hoping that these fumes might have been contributing to the SES, but alas I was just getting my hopes up.


First out of the shop (was too low to drive without scraping everywhere) (now at 15,000 miles)


Back at a reasonable height



Still to come (off @ Morr getting refinished)

Iíll be trying out some RE-11ís this time, though I was very happy with the PSS. The RE-11ís were on sale, and the PSS were on backorder for the rears. The car is a summer car
For those in Canada that havenít tried to ship wheels to the states for any reason let me just say, if at all possible drive over the border and ship these from within the US. The amount of paperwork and hoops Iíve had to jump throughÖ


Once the wheels are on and I've had a chance to detail, I'll get some better photos and update the thread.

I wanted to take a moment to throw out some well-deserved thank yous.

Thanks to Rich from GTB Performance. This guy answered countless PM's, took care of special requests and all purchases went perfectly.
Thanks to Donovan for the quick shipping and good condition euro headers.
Thanks to Geauxkart for taking the hands-on approach to fix the DKF parts up by adding the EGT bung, again answering a ton of questions and sending the most securely packaged parts I've ever seen.
Thanks to the zpost community for continuing to be one of the more supportive communities out there. I've learned a ton from this site and hope to be able to start contributing as I learn a little more.



Thanks to you all for the read. Now, bring on the sun!

__________________
_______________________________________

2006 Z4MR / RPI / Gruppe M / Euro / DKF / KW V3 / Morr vs8.2
Appreciate 0
      03-18-2014, 10:28 AM   #2
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1477
Rep
11,806
Posts

Drives: Z4M, X3 35i, 328xi
Join Date: Apr 2008
Location: CT

iTrader: (92)

Garage List
Great story man, and congrats on the car, welcome to the forum.
__________________
Follow for latest mods
Appreciate 0
      03-18-2014, 11:07 AM   #3
Beedub
Major General
United Kingdom
333
Rep
5,222
Posts

Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

i don't see why those 300 cell should cause CEL light to be honest.... unless the 02 sensor position is poor...... the Super sprint 100 cell units don't cause CEL ..... may be something else a miss their....
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      03-18-2014, 11:11 AM   #4
Jimswift
Private
Canada
5
Rep
50
Posts

Drives: 2006 Z4MR
Join Date: Mar 2011
Location: Vancouver, Canada

iTrader: (2)

Quote:
Originally Posted by Beedub View Post
i don't see why those 300 cell should cause CEL light to be honest.... unless the 02 sensor position is poor...... the Super sprint 100 cell units don't cause CEL ..... may be something else a miss their....
Yea, my gut feel tells me that you are right. I'll definitely be looking into this further.
__________________
_______________________________________

2006 Z4MR / RPI / Gruppe M / Euro / DKF / KW V3 / Morr vs8.2
Appreciate 0
      03-18-2014, 12:28 PM   #5
DEG
First Lieutenant
60
Rep
317
Posts

Drives: 2007 Z4 MR
Join Date: Jul 2010
Location: Michigan

iTrader: (0)

Nice story and welcome to forum as well. Nice looking ride! Looking forward to seeing the new wheels.
Appreciate 0
      03-18-2014, 03:26 PM   #6
z4mcoupe
boon
z4mcoupe's Avatar
United_States
9
Rep
105
Posts

Drives: 4 wheels
Join Date: Apr 2009
Location: my house

iTrader: (0)

Thank you for sharing. I wish my mom was as cool as yours.
__________________
Appreciate 0
      03-18-2014, 03:51 PM   #7
Geauxkart
Second Lieutenant
Geauxkart's Avatar
11
Rep
280
Posts

Drives: 2007 Z4 M Coupe Sepang
Join Date: Jan 2012
Location: Baton Rouge, LA

iTrader: (3)

Glad to hear winter is over for you!
Hope you get the CEL sorted out, I am surprised you are throwing a code.
When the shop relocated the O2 sensors, did they cut and splice the wires, or just unfold and reroute? Sounds like folks have issues when cutting and splicing.

Good luck with everything, thanks for the good word on the Section 1, post up some pics when you get the wheels back!
Appreciate 0
      03-18-2014, 06:20 PM   #8
itdnwiwbp
Major
65
Rep
1,443
Posts

Drives: 330iZHP
Join Date: Jun 2012
Location: Long Beach, CA

iTrader: (10)

Good story and welcome. DKF experience makes me nervous. That's 2 for 2 that I've heard of having CEL issues. Hope we didn't throw our money away.
__________________
Appreciate 0
      03-18-2014, 06:52 PM   #9
Jimswift
Private
Canada
5
Rep
50
Posts

Drives: 2006 Z4MR
Join Date: Mar 2011
Location: Vancouver, Canada

iTrader: (2)

Quote:
Originally Posted by Geauxkart View Post
Glad to hear winter is over for you!
Hope you get the CEL sorted out, I am surprised you are throwing a code.
When the shop relocated the O2 sensors, did they cut and splice the wires, or just unfold and reroute? Sounds like folks have issues when cutting and splicing.

Good luck with everything, thanks for the good word on the Section 1, post up some pics when you get the wheels back!
The shop didn't splice any wires - they were actually very familiar with the install and have done it before. The technician was actually pretty proud of the work done and spent 20 minutes talking to me about it and walking through what he did. I'll keep this thread posted if I am able to find a solution without a tune. They did tell me that the sensor was working, but that it wasn't seeing a big of enough difference between the O2 and the EGT.
__________________
_______________________________________

2006 Z4MR / RPI / Gruppe M / Euro / DKF / KW V3 / Morr vs8.2
Appreciate 0
      03-18-2014, 09:49 PM   #10
Yvette
Major General
Canada
657
Rep
7,373
Posts

Drives: M
Join Date: Sep 2006
Location: Vancouver

iTrader: (18)

maybe i should have gotten roadster lol!
Appreciate 0
      03-19-2014, 07:26 AM   #11
Psychodo
Private
Psychodo's Avatar
0
Rep
67
Posts

Drives: 2013 Boxster S
Join Date: Feb 2014
Location: Denver, CO

iTrader: (0)

Quote:
Originally Posted by ongnoi View Post
Thank you for sharing. I wish my mom was as cool as yours.
+1

Thanks for sharing
Appreciate 0
      03-19-2014, 08:15 AM   #12
Walkurie
Lieutenant
Walkurie's Avatar
United_States
7
Rep
452
Posts

Drives: 06 M Roadster / 99 Jaguar XK8
Join Date: Mar 2010
Location: Surf City, CA

iTrader: (2)

Great story and nice car. Welcome to the forum. Don't give up on the CEL, you will eventually find a solution.
__________________
Vibra Technics engine mounts / Rogue trans mounts / Stoptech brakes / original owner
Appreciate 0
      03-19-2014, 03:03 PM   #13
johanness
Banned
53
Rep
1,739
Posts

Drives: 2008 Z4MC
Join Date: Aug 2010
Location: Seattle, Vancouver

iTrader: (3)

Garage List
Quote:
Originally Posted by Jimswift View Post
The bad news. After about 50 miles, the SES light came on. I spoke with the shop and they were fairly confident that the new cat wasn't doing enough.
I went through a hair-pulling process with my SES after Euro headers and relocating O2's and EGT.

Turns out it was a simple gasket issue. Dipshit shop figured they'd reuse the doughnut and there was a leak. Literally a PIN-HOLE leak can cause the fault.

Worth checking before you dig deep. I ended up doing everything from shortening my bungs (TWICE! Grr - what bullshit) to pulling the system down 3 times.

Here's the thread: http://www.zpost.com/forums/showthre...t=euro+headers
Appreciate 0
      03-19-2014, 09:10 PM   #14
3point0
Lieutenant
3point0's Avatar
Canada
20
Rep
415
Posts

Drives: 2005 z4 3.0
Join Date: Jun 2012
Location: Vancouver

iTrader: (2)

Garage List
2006 Audi S4 Avant  [0.00]
2005 BMW Z4  [2.75]
Nice story, great car.

Will have to keep an eye out for you at meets this year, if we ever get around to having any, welcome to the club!
__________________

2005 Z4 3.0 steptronic | TiSilver on Black | sport & premium package | 108s | Msport seats | wind deflector
OMP strut bar | blacked out emblems | de-french-fried | sound gen | DIY aux input | custom speedo logos | stubby antenna | polished exhaust tips
Appreciate 0
      05-25-2016, 12:19 AM   #15
Jimswift
Private
Canada
5
Rep
50
Posts

Drives: 2006 Z4MR
Join Date: Mar 2011
Location: Vancouver, Canada

iTrader: (2)

Figured I should update this thread with the recent photos


























on Flickr
__________________
_______________________________________

2006 Z4MR / RPI / Gruppe M / Euro / DKF / KW V3 / Morr vs8.2
Appreciate 0
      05-25-2016, 07:41 AM   #16
inTgr8r
Lieutenant General
inTgr8r's Avatar
Canada
2031
Rep
11,417
Posts

Drives: M2 Comp
Join Date: Mar 2006
Location: Toronto

iTrader: (10)

Very nice, the car s looking great!
Appreciate 0
      05-25-2016, 11:52 AM   #17
SaltyNC
Captain
SaltyNC's Avatar
360
Rep
870
Posts

Drives: 2006 BMW Z4M Roadster
Join Date: Oct 2015
Location: NC

iTrader: (2)

Garage List
Good looking wheels!

Salty
__________________
2006 BMW Z4M Interlagos Blue/Black
Aux Port|LED Interior|LED Strip Trunk|Underseat First Aid Box|Stubby Antenna|Intravee II|BMW Oil Change Kit|Top Down Side Panels|Vibra Technics Engine Mounts|Rogue Trans Mounts|Engine Mount Bolts Upgrade|RS Windblocker|Euro Front Plate|M5 Illum Shift Knob|Supersprint Powerloop Exhaust|Gruppe-M Intake|RPI Scoop|Black Grills|19x8.5 ET35 F 19x9.5 ET22 R Sportline 8s PSS| Besian Vanos|CDV Delete
Appreciate 0
      06-15-2016, 02:34 PM   #18
Beedub
Major General
United Kingdom
333
Rep
5,222
Posts

Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

damn those wheels are hard to beat.
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      06-15-2016, 11:30 PM   #19
Vanne
Down Under!!
Vanne's Avatar
United Arab Emirates
1330
Rep
4,110
Posts

Drives: 2007 Z4MC
Join Date: Mar 2013
Location: Dubai

iTrader: (4)

Awesome car, loved the read too ill be interested where you take the car from here
__________________
2007 EuroSpec Z4///MC - Building/Developing Z4 GT3
Powered by
Appreciate 0
      08-10-2021, 08:21 PM   #20
Jimswift
Private
Canada
5
Rep
50
Posts

Drives: 2006 Z4MR
Join Date: Mar 2011
Location: Vancouver, Canada

iTrader: (2)

Sadly the car hasn't had enough love in these covid times, but here's a couple recent photos.

BMW-1

BMW-2


Bonus picture of the stablemate
Jag-4
__________________
_______________________________________

2006 Z4MR / RPI / Gruppe M / Euro / DKF / KW V3 / Morr vs8.2
Appreciate 2
JVDHM24.00
v3.2mc84.50
      08-11-2021, 02:28 PM   #21
racerbruce
Colonel
racerbruce's Avatar
3271
Rep
2,528
Posts

Drives: 2007 Z4MR Imola Red
Join Date: Dec 2009
Location: Seattle

iTrader: (1)

Greetings from down the street (Seattle)
Just read your initial post - condolences in the loss of your mother.
__________________
Racerbruce
OZ Rims / Bilstein B6 Struts & Shocks / Eibach Pro-Kit Springs / ZHP Control Arms / RE Diablo Exhaust / RPi Air Intake / BMC Air Filter / CDV / RE Trans Mounts / 3M Paint Protection / TMS CF Grilles / TK CF Mirrors / Skyer CF Spoiler / CF Antenna / M Pedals & Dead Pedal / CoCo Floor Mats / WeissLicht LED Rear Turn Signal Lamps / #748 of 3,042
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:06 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST