ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Cosmetics Modification (Exterior/Interior) Discussions
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      07-08-2018, 09:39 AM   #1
jns_e85
Second Lieutenant
jns_e85's Avatar
52
Rep
226
Posts

Drives: '04 z4 3.0i, '06 z4M, '17 M2
Join Date: Feb 2014
Location: Chicago Area

iTrader: (2)

New Convertible Top Motor Stopped Working After Trunk Relocation?

A couple of months ago, I replaced my top motor on my Z4M after the old one went bad, and decided to undertake the trunk relocation. It worked well for a couple of months, then the motor started to take a lot longer to bring the top up, and then inevitably it stopped working altogether.

As of yesterday, the motor doesn't bring the top down either but will still run to put the top down, but it won't run to put the top up. I have to engage the bypass to move the top up or down at all. I checked for any hydraulic leaks, and there were none I can find. I looked for rubbed or cut wires, and I couldn't find anything. Outside of the motor just being defective, I cannot think of what else could be wrong.

Anyone else experienced this or have any ideas? FWIW, I had the top of the motor angled to the front of the car in the trunk if that makes a difference...
__________________


2017 M2 - Bone stock...for now
2006 Z4M - Epic Tune / Eventuri CAI / Euro Headers / Stromung / FA 500 / AS SSK / Arc 8s
2004 Z4 3.0i - Gone, but not forgotten!
Appreciate 0
      09-18-2019, 10:05 PM   #2
apexhittinbull
New Member
17
Rep
25
Posts

Drives: E85 M
Join Date: Oct 2017
Location: SoCal

iTrader: (0)

Were you able to fix the issue?
I have the same problem after new motor and relocation to the trunk.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:36 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST