ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > Regional Forums > UK
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-08-2023, 03:55 PM   #1
pompeylewis
Registered
0
Rep
1
Posts

Drives: BMW Z4 3.0SI
Join Date: May 2023
Location: Hampshire UK

iTrader: (0)

Cranks but no start

Got a 2008 3.0 SI high miles at 140,000 but was a bargain price from a friend moving abroad, 1800.

Ran fine when I got it but decided to do all the things needing doing on the engine at the same time.

Rocker cover gasket and oil filter housing seals, reconditioned alternator, new drive belt and tensioner.

But it back together and wouldn't start. Cranked and fired on three once but wouldn't fire after that.

Codes are 2A9E and 2A9F which are both camshaft sensors.

I have cleared these and the engine turns over but doesn't fire.

Coil packs replaced 2020.

Checked for spark and no spark on any of the plugs.

Earth to the coil packs is fine have checked a number of times.

the permanent 12 v to the coil packs are fine.

The cam sensors have been disconnected and the permanent 12 volt is there and the earth.

The fuses have been checked and all seem fine.

The valvetronic motor has been reset but I didn't think this would stop a start anyways.

Can anyone add a good way forward with fault diagnostics as I am mega confused.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:43 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST