ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-12-2020, 01:13 PM   #1
AK72
Second Lieutenant
AK72's Avatar
Canada
104
Rep
257
Posts

Drives: 2007 BMW Z4 m Coupe
Join Date: Apr 2013
Location: Toronto

iTrader: (0)

Headlights orange light anomaly

Need your help guys just in case if someone had this anomaly before me

My 2006 BMW Z4 M headlights orange light/turn signal goes on when I press brake pedal while car moving and turns off when I release brake , if I try to press brake pedal again they won't go on so only when car moving.
Thanks in advance

Forgot to mention on how I find out about this, from reflection on the car that on the front of me

Last edited by AK72; 06-16-2020 at 06:30 AM..
Appreciate 0
      06-15-2020, 09:41 AM   #2
AK72
Second Lieutenant
AK72's Avatar
Canada
104
Rep
257
Posts

Drives: 2007 BMW Z4 m Coupe
Join Date: Apr 2013
Location: Toronto

iTrader: (0)

Strange but nobody replying, I guess I own unic Z4 lol
Appreciate 0
      06-15-2020, 11:33 AM   #3
3GFX
Captain
3GFX's Avatar
Canada
623
Rep
809
Posts

Drives: 2003 BMW Z4 3.0i
Join Date: Sep 2015
Location: Ontario

iTrader: (0)

Sounds like a wiring problem but I don't think I quite understand what is happening based on your description.

I'll summarize though. Nothing in your headlight should be turning on or off at the same time as the braking lights. I would suggest you try to take a video of the scenario.
Appreciate 0
      06-15-2020, 01:06 PM   #4
wdb
dances with roads
wdb's Avatar
United_States
2235
Rep
3,030
Posts

Drives: '07 Z4MC, '07 E93 328i
Join Date: Jul 2015
Location: the perimeter

iTrader: (4)

Do the brake lights come on with the turn signals, or when the parking lights are turned on?
Appreciate 0
      06-15-2020, 02:09 PM   #5
Sterling Roadster
Second Lieutenant
Canada
32
Rep
210
Posts

Drives: 2003 Z4 3.0i
Join Date: Aug 2015
Location: Toronto

iTrader: (0)

Either a wiring problem or a really bizarre coding option. I think I saw that as an option when I was coding my car. Don't know why you would want that.
Appreciate 0
      06-16-2020, 06:26 AM   #6
AK72
Second Lieutenant
AK72's Avatar
Canada
104
Rep
257
Posts

Drives: 2007 BMW Z4 m Coupe
Join Date: Apr 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by wdb View Post
Do the brake lights come on with the turn signals, or when the parking lights are turned on?
Its actually way around -
turn signal bulb comes on (no blinking) when apply I apply brakes and stay on until I release pedal.

Appreciate 0
      06-16-2020, 06:28 AM   #7
AK72
Second Lieutenant
AK72's Avatar
Canada
104
Rep
257
Posts

Drives: 2007 BMW Z4 m Coupe
Join Date: Apr 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Sterling Roadster View Post
Either a wiring problem or a really bizarre coding option. I think I saw that as an option when I was coding my car. Don't know why you would want that.
I think coding but yes its bizzare In what coding software you saw that ?

Last edited by AK72; 06-16-2020 at 06:56 AM..
Appreciate 0
      06-16-2020, 08:26 AM   #8
3GFX
Captain
3GFX's Avatar
Canada
623
Rep
809
Posts

Drives: 2003 BMW Z4 3.0i
Join Date: Sep 2015
Location: Ontario

iTrader: (0)

Quote:
Originally Posted by AK72 View Post
I think coding but yes its bizzare In what coding software you saw that ?
Slippery slope....INPA is what you're after. But google it.

I think this is a wiring thing, easier to check than going and buying software. Check your headlights and tail lights to see any wiring that doesn't look like it is from factory. Someone may have tried to tie in the parking lights and wired to the brake light by accident.

Good luck!
Appreciate 0
      06-16-2020, 08:03 PM   #9
pungo
Major
pungo's Avatar
United_States
251
Rep
1,241
Posts

Drives: 2007 Z4 ///M Coupe
Join Date: Nov 2007
Location: MD

iTrader: (5)

Garage List
Have you done any coding to the LSZ module?
Are you the original owner? If not, maybe the previous owner did?

Write my 2007 Z4MC stock LSZ coding to yours and see if it corrects the issue. Or at least use NCS Dummy to compare your LSZ to mine to see if any differences stand out.

E86_LSZ.C36_FSW_PSW.TRC.txt
Appreciate 0
      06-17-2020, 05:16 AM   #10
AK72
Second Lieutenant
AK72's Avatar
Canada
104
Rep
257
Posts

Drives: 2007 BMW Z4 m Coupe
Join Date: Apr 2013
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by pungo View Post
Have you done any coding to the LSZ module?
Are you the original owner? If not, maybe the previous owner did?

Write my 2007 Z4MC stock LSZ coding to yours and see if it corrects the issue. Or at least use NCS Dummy to compare your LSZ to mine to see if any differences stand out.

Attachment 2340571
Thanks a lot I will compare
Appreciate 0
      06-17-2020, 11:39 AM   #11
wdb
dances with roads
wdb's Avatar
United_States
2235
Rep
3,030
Posts

Drives: '07 Z4MC, '07 E93 328i
Join Date: Jul 2015
Location: the perimeter

iTrader: (4)

Quote:
Originally Posted by AK72 View Post
Its actually way around -
turn signal bulb comes on (no blinking) when apply I apply brakes and stay on until I release pedal.

Yes I understand that. I asked if the opposite were true, which could indicate a wiring issue as the cause.
Appreciate 0
      06-17-2020, 03:20 PM   #12
Sterling Roadster
Second Lieutenant
Canada
32
Rep
210
Posts

Drives: 2003 Z4 3.0i
Join Date: Aug 2015
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by AK72 View Post
I think coding but yes its bizzare In what coding software you saw that ?
I believe I saw it on my Carly app. But it would be annoying to spend 200 bucks just to uncode one thing. If it does even work. So I would ask around someone near you.
Appreciate 0
      06-17-2020, 08:14 PM   #13
pungo
Major
pungo's Avatar
United_States
251
Rep
1,241
Posts

Drives: 2007 Z4 ///M Coupe
Join Date: Nov 2007
Location: MD

iTrader: (5)

Garage List
Quote:
Originally Posted by Sterling Roadster View Post
I believe I saw it on my Carly app. But it would be annoying to spend 200 bucks just to uncode one thing. If it does even work. So I would ask around someone near you.
Carly can't do anything NCSexpert can't do, so I wouldn't waste money on Carly, which BTW, charges you every year for the privilege to continue to use "their" software.

Comparing the stock LSZ I provided with the bizarre behaving one in this post will determine if the problem is in the coding or not.
Appreciate 0
      07-02-2020, 11:59 PM   #14
Willy Sea
Private
26
Rep
91
Posts

Drives: BMW M Coupe S54, E36 M3 Evo,
Join Date: May 2019
Location: New Zealand

iTrader: (1)

Quote:
Originally Posted by pungo View Post
Carly can't do anything NCSexpert can't do, so I wouldn't waste money on Carly, which BTW, charges you every year for the privilege to continue to use "their" software.

Comparing the stock LSZ I provided with the bizarre behaving one in this post will determine if the problem is in the coding or not.
Was this ever resolved? Curious as think we have the same or similar after adding the BFD to our coupe.
Appreciate 0
      07-04-2020, 09:44 AM   #15
maupineda
Lieutenant
United_States
65
Rep
422
Posts

Drives: E86 Z4MC
Join Date: Jul 2012
Location: Detroit, MI

iTrader: (3)

That behavior would be more wiring related than coding. Unless someone really tried mapping pins. Like mentioned above, code it back to stock as that is easy and quick to rule out any coding issues. I have coded my car to US spec to turn xenons as DRLs. I cam give you mine for reference too.
Appreciate 1
AK72103.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:30 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST