ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      01-17-2019, 11:20 AM   #155
njburns
Registered
0
Rep
2
Posts

Drives: Z4 E85 2.5i
Join Date: Jan 2019
Location: DOWN

iTrader: (0)

Thanks for the advice :-)
Appreciate 0
      09-11-2019, 10:55 AM   #156
raptor_demon
New Member
raptor_demon's Avatar
United_States
6
Rep
17
Posts

Drives: 2006 z4 3.0i sport pkg
Join Date: Mar 2010
Location: NC

iTrader: (0)

Garage List
2006 BMW Z4  [2.75]
Quote:
Originally Posted by raptor_demon View Post
well after 5 years and 2 children later, im finally going to do this mod. any chance we could get the photos updated?

thanks
Raptor
Well turns out i was wrong, i didn't do this back in 2017, i did however finish this upgrade on Monday!


so i have the 3 stage manifold installed, but i have not flashed the ecu.

i was looking in the INPA software and under the VIMDISA menu i was able to test the disa valves. what is interesting is when driving the valves are actuating, and i can feel the power increase in the 5k rpm range. is this normal for a stock 3.0i without the ECU flash?
Appreciate 0
      09-11-2019, 09:51 PM   #157
Mantraxalos
Enlisted Member
11
Rep
45
Posts

Drives: 2006 325i Manual
Join Date: Nov 2016
Location: Detroit/NY

iTrader: (0)

Garage List
2004 330CI  [0.00]
2005 330I ZHP  [0.00]
2006 330I  [0.00]
2007 Z4 3.0  [0.00]
2006 325I  [0.00]
RSA delete failed on me

RSA delete failed on me, now my car just cranks. I have the bimmergeeks cable with latency set to 1 on COM 1 and the latest version of their standard tools. My laptop has Windows 10 on it.
I have an 07 3.0 and was tempted by the bimmerlabs batch file. I also posted at e90post as there are many there with so much experience in flashing. If anyone can help I'd be very grateful. Thank you.

This is the error that I received.


https://1drv.ms/u/s!AnlavCs9oGBdlM1dzxn-lYudrwEfhQ
Appreciate 0
      10-24-2019, 08:16 PM   #158
rjahl
Lieutenant Colonel
rjahl's Avatar
616
Rep
1,723
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by Mantraxalos View Post
RSA delete failed on me, now my car just cranks. I have the bimmergeeks cable with latency set to 1 on COM 1 and the latest version of their standard tools. My laptop has Windows 10 on it.
I have an 07 3.0 and was tempted by the bimmerlabs batch file. I also posted at e90post as there are many there with so much experience in flashing. If anyone can help I'd be very grateful. Thank you.

This is the error that I received.


https://1drv.ms/u/s!AnlavCs9oGBdlM1dzxn-lYudrwEfhQ
Being a month old, I'm hopeful you resolved this.

I can assure you the Bimmerlabs files for the 3.0 work.
Appreciate 0
      12-29-2019, 01:02 AM   #159
Mantraxalos
Enlisted Member
11
Rep
45
Posts

Drives: 2006 325i Manual
Join Date: Nov 2016
Location: Detroit/NY

iTrader: (0)

Garage List
2004 330CI  [0.00]
2005 330I ZHP  [0.00]
2006 330I  [0.00]
2007 Z4 3.0  [0.00]
2006 325I  [0.00]
I never did resolve it. After about a month without the Z4, I attempted to flash the old 3.0 file back on and it worked without issues. I'll try again in the spring for the SI power.
Appreciate 0
      01-01-2020, 06:13 PM   #160
Terraphantm
Captain
201
Rep
722
Posts

Drives: E46 M3 Coupe
Join Date: Apr 2009
Location: N/A

iTrader: (1)

The bimmerlabs files should work. If one prefers, I can also supply a program variant that ignores the hours counter on the DME and allows the powerclass to be changed - that would allow you to flash an unmodified 3.0si tune.
Appreciate 0
      01-14-2020, 11:04 AM   #161
dano328xi
New Member
2
Rep
12
Posts

Drives: 328xi '07 -- 650i x drive '12
Join Date: Nov 2018
Location: Marion, OH

iTrader: (0)

I used Bimmerlabs to flash to the stage 3. One of my disa valves broke so I'm going back to stock. I already put the old manifold on. What files do I use to flash back to original? Also, Bimmerlabs website is down. thanks
Appreciate 0
      01-14-2020, 07:59 PM   #162
Terraphantm
Captain
201
Rep
722
Posts

Drives: E46 M3 Coupe
Join Date: Apr 2009
Location: N/A

iTrader: (1)

Quote:
Originally Posted by dano328xi View Post
I used Bimmerlabs to flash to the stage 3. One of my disa valves broke so I'm going back to stock. I already put the old manifold on. What files do I use to flash back to original? Also, Bimmerlabs website is down. thanks
Just do an "upgrade" with WinKFP, that should flash it back to the latest version of a stock tune
Appreciate 0
      01-15-2020, 07:20 PM   #163
rjahl
Lieutenant Colonel
rjahl's Avatar
616
Rep
1,723
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by dano328xi View Post
I used Bimmerlabs to flash to the stage 3. One of my disa valves broke so I'm going back to stock. I already put the old manifold on. What files do I use to flash back to original? Also, Bimmerlabs website is down. thanks
Bimmerlabs was down for a short period. Hassmachine has it up and running again.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:48 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST