ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Navigation, Audio, Bluetooth, Stereo, Electronics Talk
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      12-29-2019, 02:05 PM   #1
rsutoratosu
Lieutenant
33
Rep
541
Posts

Drives: Z4 3.0i
Join Date: Mar 2011
Location: Chicago, IL

iTrader: (0)

License plate led retorfit water issue

Anyone ever use this led instead of the swapping out bulbs ? Curious if there's any weather related issue. I figure for my license plate light rear camera, I can wire up the light to a t10 base and plug it into the factory connectors like how these led lights are setup. Just worry about rain/water







https://www.ebay.com/itm/2-Bulbs-Set...-/302453274675
__________________
-Roranji
Appreciate 0
      12-29-2019, 07:39 PM   #2
koruptor
Private First Class
koruptor's Avatar
United_States
23
Rep
153
Posts

Drives: 2008 Z4 3.0si Coupe
Join Date: Feb 2015
Location: Los Angeles, CA

iTrader: (0)

Garage List
I installed something similar on mine. I even drilled out a hole on one end and installed a backup cam. The LED's super bright and helps illuminate surroundings for the camera. I haven't had any failures or issues due to weather. It's been going strong almost five years now.

What I don't remember is if installing the light was plug-and-play or if I had to do any soldering. It was the least of my problems though, because wiring up the backup cam was the most labor intensive.
__________________
2008 Z4 3.0si Coupe
Appreciate 1
      12-29-2019, 07:59 PM   #3
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1333
Rep
11,751
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (91)

Garage List
Maybe Iím missing something but why does it matter what bulb or housing you go with when it comes to powering an accessory? Why canít you swap just bulbs only and tap the same wire thatís in the original housing?

Edit
Never mind I see the camera is part of the aftermarket light housing. I thought you said it was rear license [plate] frame.
__________________
Follow for latest mods

Last edited by 3002 tii; 12-29-2019 at 08:07 PM..
Appreciate 1
      12-30-2019, 09:45 AM   #4
rsutoratosu
Lieutenant
33
Rep
541
Posts

Drives: Z4 3.0i
Join Date: Mar 2011
Location: Chicago, IL

iTrader: (0)

I'm only asking because I read a few reviews where the led died.. so either it died because it was cheaply made, ie heat or cheap parts or it died because that connector isn't waterproof and some how water got into the wiring.

Yeah they made the camera integrate into the light, so it looks more oem. My other option was the cut the original light enclosure and screw the camera in and silicone it. Its an option if the led on that camera dies. I have order the t10 pig tail wire, i found some water proof connectors thingy to try.. its coming in a few days ill see if the connector really water poof.

I like the bmw setup, when i took the bulb out out, it was definitely water tight.. I dont see any water in there after 10 years..
__________________
-Roranji
Appreciate 0
      12-30-2019, 09:58 AM   #5
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1333
Rep
11,751
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (91)

Garage List
Quote:
Originally Posted by rsutoratosu View Post
I'm only asking because I read a few reviews where the led died.. so either it died because it was cheaply made, ie heat or cheap parts or it died because that connector isn't waterproof and some how water got into the wiring.

Yeah they made the camera integrate into the light, so it looks more oem. My other option was the cut the original light enclosure and screw the camera in and silicone it. Its an option if the led on that camera dies. I have order the t10 pig tail wire, i found some water proof connectors thingy to try.. its coming in a few days ill see if the connector really water poof.

I like the bmw setup, when i took the bulb out out, it was definitely water tight.. I dont see any water in there after 10 years..
My Philips Ultinon are going strong without error... day and night shot
Attached Images
  
__________________
Follow for latest mods
Appreciate 1
      12-30-2019, 05:06 PM   #6
rsutoratosu
Lieutenant
33
Rep
541
Posts

Drives: Z4 3.0i
Join Date: Mar 2011
Location: Chicago, IL

iTrader: (0)

too bright... in a bank robbery, i want the dimmest led.. lol

its like you can light up the rear just with those
__________________
-Roranji
Appreciate 0
      12-30-2019, 06:15 PM   #7
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1333
Rep
11,751
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (91)

Garage List
Quote:
Originally Posted by rsutoratosu View Post
too bright... in a bank robbery, i want the dimmest led.. lol

its like you can light up the rear just with those
And how often are you robbing banks?
__________________
Follow for latest mods
Appreciate 0
      12-31-2019, 04:21 PM   #8
rsutoratosu
Lieutenant
33
Rep
541
Posts

Drives: Z4 3.0i
Join Date: Mar 2011
Location: Chicago, IL

iTrader: (0)

Quite often.. to pay for this hobby... lol

Going fishing tomorrow... fish the wires out of the bumper and into the trunk..
Reverse led light bar & get that camera installed.

__________________
-Roranji
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:36 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST