ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > Z4 DIY (Do It Yourself) Articles
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-25-2018, 04:40 PM   #1
MrBladest
Registered
0
Rep
1
Posts

Drives: Z4 E85, BMW 320ED F31
Join Date: May 2018
Location: Belgium

iTrader: (0)

Z4 E85 Automatic top not working

Hi,

After replacing the hydraulic motor, the top won't move.
I've tested the motor when the roof was on my garage floor and it worked.

The top red light keeps blinking. When I push either of the buttons, the catches open for a second, I have to push the button several times before the roof is completely unlatched. Besides that nothing happens, windows don't go down and roof doesn't move. To close the catches, I have to use an allen wrench.

I've connected with a K+DCAN cable, in INPA I get error 68 'Antrieb fanhaken: Offene Last beim Verriegeln' (Google Translate: Drive fan hook: open load when locking) In Ista+ I get error 000044 'CVM: Drive, cowl panel, open circuit'

I think the sensor for the catches doesn't work or doesn't know what position it is in.

I've already tried disconnecting the battery for 10 minutes, no change there.

Has anybody come across this error before?
Appreciate 0
      11-20-2019, 10:39 AM   #2
Inkwel84
Registered
0
Rep
2
Posts

Drives: 2004 Z4 2.5i
Join Date: Nov 2019
Location: USA

iTrader: (0)

Curious what your problem was?
Appreciate 0
      01-30-2020, 10:27 PM   #3
Kazansky
Private
United_States
10
Rep
65
Posts

Drives: MB_GL350
Join Date: Oct 2018
Location: New Orleans

iTrader: (0)

Quote:
Originally Posted by Inkwel84 View Post
Curious what your problem was?
I had a similar issue and it was $35 sensor. Took about an hour to replace by someone who knows 🙂
Appreciate 0
      01-31-2020, 10:22 AM   #4
Huz-Z
Brigadier General
Huz-Z's Avatar
Canada
597
Rep
3,712
Posts

Drives: Z4 3.0si, 328 XDrive, X5 35i
Join Date: Aug 2009
Location: Canada

iTrader: (0)

I presume that you have checked the tray that is visible in the back window? It raises up via two knobs near each trunk lid hinge to make more room in the trunk. But when you do that, the tray occupies the same space as the lowered roof so the roof will not lower. Make sure that the tray is in the lowest position.

(A Hail Mary, here I know, but worth a try - good luck!)
__________________
Huz-Z


BMW Z4 3.0si Roadster. Montego Blue Metallic. Premium and Sport Package.
Appreciate 0
      01-31-2020, 07:02 PM   #5
SwissArmy
Why so serious?
SwissArmy's Avatar
Canada
115
Rep
724
Posts

Drives: BMW Z4 3.0i; BMW X5 35i
Join Date: Dec 2012
Location: Toronto

iTrader: (1)

Microswitch in the trunk is not properly engaged
Appreciate 0
Post Reply

Bookmarks

Tags
roof, soft top, z4 e85

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:21 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST