ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      06-14-2018, 11:00 AM   #1
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

Car wont unlock

I have read on here about the issue but only a few threads and none confirm my issue unless I missed a thread somewhere.

My issue- I use the key fob or the key in the door and every so often the door plunger doesn't come up all the way and sounds like its struggling. I try and lock and unlock it again and sometimes that works or the key in the door works. It hasn't happened in awhile but today it took 5 min to get the door unlocked and don't want to risk not being able to get in at all. When this happens, the passenger door plunger doesn't come up at all and that door has no tumbler to even try a key in.

My thoughts are the Bowden cable getting stuck, the actuator or the GM5 Module.

Id like to think/hope its not the GM5 since the door is getting a signal to unlock, but I also don't know much about them.

When out of work I plan on taking to panel off and looking around. If anyone has any suggestions or solutions that would be great. Don't want to get locked out of my own car not being able to get back in when out in the city.

Thank you
Appreciate 0
      06-14-2018, 02:09 PM   #2
StickMon
My other car is on Mars
StickMon's Avatar
United_States
492
Rep
2,893
Posts

Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (1)

The passenger door should unlock with the fob if you press the button twice.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      06-14-2018, 05:51 PM   #3
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

Update. I took the panel off and noticed that my car recently wont unlock or lock with the doors open. Then 5 min later after looking to the Bowden cable I tried the remote again for shits and giggles and everything worked perfectly. I tested the remote by locking and unlocked a few times but the problem came back and the drivers door actuator seemed to be sticking like it was under friction. Then out of no where nothing worked on the remote. No motors were running and usually you hear a click from a solenoid and nothing. unlocking or locking doors didn't work at all on both my remotes.
Appreciate 0
      06-14-2018, 08:00 PM   #4
ZeD4Mr
Captain
ZeD4Mr's Avatar
Canada
188
Rep
955
Posts

Drives: MR
Join Date: Dec 2009
Location: B.C. Canada

iTrader: (15)

Did you try using the center unlock button? maybe is the remote? just my2c
__________________
.
.

Supersprint Powerloops, SKYER CF spoiler, AS SSK, AA tune, Vibra Technics, Eventuri, Stoptech lines & pads, RE trans mount, OE hardtop
Appreciate 0
      06-14-2018, 08:57 PM   #5
kaybat
Private First Class
kaybat's Avatar
United_States
35
Rep
199
Posts

Drives: '06 Z4MR E85,'11 335i
Join Date: Aug 2013
Location: Ormond Beach,Fla

iTrader: (0)

Garage List
'06 Z4M  [0.00]
2011 335i Coupe  [0.00]
on my 03, the door module went south,had to be replaced.(that's what the dealer called it)
__________________
Ken SCCA/BMWCCA
Appreciate 0
      06-15-2018, 10:05 AM   #6
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

The center console button I don't think has ever worked. I used both remotes and got them both working again. Realized with the drivers door open, nothing works unless its closed. My issue is still intermittent. The actuator seems to be acting up and sometimes when I push the door plunger down, it goes down very easy, but other times its like I'm fighting the motor in it. Not sure if that's still a Bowden cable issue or an actuator issue.

Have the neg off the batt and going to take out the air bag and look at cable and if I'm feeling up to is, taking out the actuator and cleaning or replacing.
Appreciate 0
      06-15-2018, 07:56 PM   #7
kaybat
Private First Class
kaybat's Avatar
United_States
35
Rep
199
Posts

Drives: '06 Z4MR E85,'11 335i
Join Date: Aug 2013
Location: Ormond Beach,Fla

iTrader: (0)

Garage List
'06 Z4M  [0.00]
2011 335i Coupe  [0.00]
dude, less caffeine. ;-)
i wouldn't touch the air bag unless your getting a code. get an OBD sensor, and see what it says.

again, it was common for the door sensor modules to fail on the early e85's.Mine did exactly what your is doing.(cost $700 to fix)
__________________
Ken SCCA/BMWCCA

Last edited by kaybat; 06-15-2018 at 08:01 PM.
Appreciate 0
      06-18-2018, 08:04 AM   #8
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

Kaybat- just got the car and want to drive it!! Trying to fix it quick since it snows more than half the year up here.

Since the key in the door doesn't always work I decided to just go for it and take the actuator out. Much easier than most people made it seem on here so if anyone has an issue let me know. I used this link below.

https://www.pelicanparts.com/techart...eplacement.htm

I also decided to take apart the older actuator and looked inside to see the issue. Looks like one of the gears wear in the actuator and get off track, then after locking and relocking the gears reline up and works for a few weeks. Mostly writing for future people with the problem.

Ordered my new actuator from ECS tuning since the dealer wants an arm and a leg. Bowden cable looked fine but might tie it back against the bracket like some mentioned. Will update when I get the new actuator in. Don't care about the key fob working at this point, just need the key to work in the door every time.
Appreciate 0
      06-18-2018, 09:49 AM   #9
RossBMWZseries
Captain
United_States
89
Rep
744
Posts

Drives: '11 E92 328i LCI & '06 Z4MR
Join Date: Jun 2014
Location: San Juan TX

iTrader: (1)

Garage List
Not sure if this is the same thing issue I'm having (along with the rest of the symptoms) but sometimes my key fob won't unlock the car and the alarm remains ON as I can see the red nose blinking under the rear view mirror. Putting the key in the door won't unlock it either. What I do in that case, I go to the trunk, open it manually, disconnect the negative terminal, alarm goes off, reconnect negative cable, then key fob works just fine and i'm able to unlock the car.
__________________
2011 BMW 328i E92 LCI
2006 BMW Z4 M Roadster
2013 BMW S1000RR R.I.P.
1998 BMW Z3 Roadster 1.9L SOLD
Appreciate 0
      06-18-2018, 12:47 PM   #10
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

Quote:
Originally Posted by RossBMWZseries View Post
Not sure if this is the same thing issue I'm having (along with the rest of the symptoms) but sometimes my key fob won't unlock the car and the alarm remains ON as I can see the red nose blinking under the rear view mirror. Putting the key in the door won't unlock it either. What I do in that case, I go to the trunk, open it manually, disconnect the negative terminal, alarm goes off, reconnect negative cable, then key fob works just fine and i'm able to unlock the car.
Ross.
How long do you leave the neg batt cable off for to restart? I don't have an alarm on my car. I just need a backup plan for if this fails when im out and about. I heard you can use the key in the door and hold it in the unlock position and it rolls down the windows and puts the roof down, is this true?
Appreciate 0
      06-18-2018, 12:57 PM   #11
StickMon
My other car is on Mars
StickMon's Avatar
United_States
492
Rep
2,893
Posts

Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (1)

Not sure about the key in the lock, but if you hold the fob button it will roll down the windows and open the top.
Make sure you're right on top of it. The fob has notoriously poor range.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      06-18-2018, 02:33 PM   #12
RossBMWZseries
Captain
United_States
89
Rep
744
Posts

Drives: '11 E92 328i LCI & '06 Z4MR
Join Date: Jun 2014
Location: San Juan TX

iTrader: (1)

Garage List
Quote:
Originally Posted by Thormx331 View Post
Ross.
How long do you leave the neg batt cable off for to restart? I don't have an alarm on my car. I just need a backup plan for if this fails when im out and about. I heard you can use the key in the door and hold it in the unlock position and it rolls down the windows and puts the roof down, is this true?
THAT is true. Leave your key in the door, rotate left and hold that position; your windows should roll half way down and then the top drops all the way.

As far as disconnecting the negative terminal, not long really. When I remove it, within 1-2 seconds the alarm goes off so I immediately hook up the negative again so I can shut the alarm off with the key fob, at the same time unlocking the car. With or without alarm, if your key fob is able to unlock the car, then this might do the trick. I'd be lying if I told you I know exactly what the problems is but my suspicion is that somewhere there is a communication failure that doesn't allow the car to unlock, in my case, it relates to having the air bag light come up on the dashboard.
__________________
2011 BMW 328i E92 LCI
2006 BMW Z4 M Roadster
2013 BMW S1000RR R.I.P.
1998 BMW Z3 Roadster 1.9L SOLD
Appreciate 0
      06-18-2018, 02:35 PM   #13
RossBMWZseries
Captain
United_States
89
Rep
744
Posts

Drives: '11 E92 328i LCI & '06 Z4MR
Join Date: Jun 2014
Location: San Juan TX

iTrader: (1)

Garage List
Quote:
Originally Posted by StickMon View Post
Not sure about the key in the lock, but if you hold the fob button it will roll down the windows and open the top.
Make sure you're right on top of it. The fob has notoriously poor range.
This method works too BUT only if your key fob has communication with the car. If somehow that communication is not being linked, you'll be pressing the fob button all day waiting for something to happen. Now this makes me wonder; StickMon, when you get a chance try rolling the windows/top down by inserting the key in the door and holding the key in the left position. I would think this is a feature on all Z4's
__________________
2011 BMW 328i E92 LCI
2006 BMW Z4 M Roadster
2013 BMW S1000RR R.I.P.
1998 BMW Z3 Roadster 1.9L SOLD
Appreciate 0
      06-18-2018, 02:41 PM   #14
StickMon
My other car is on Mars
StickMon's Avatar
United_States
492
Rep
2,893
Posts

Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (1)

I'll try to remember to try it tonight when I leave work.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      06-18-2018, 11:23 PM   #15
StickMon
My other car is on Mars
StickMon's Avatar
United_States
492
Rep
2,893
Posts

Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (1)

So I stuck the key in the door for probably the first time in the 7 years I've owned it.
Turned CCW and held it. Door unlocked and alarm shut off. Nothing else.
Turned it back to vertical, and then back CCW and held it.
Locks quickly locked and unlocked, and then after the typical pause, windows went down 1/2 way and top went down.

Then my door wouldn't open. I think the rapid lock/unlock it did on the second try was anomalous, and it didn't fully unlock.
Unlocked it with the fob and had a nice ride home.
__________________
Warning: May contain traces of nuts.
Appreciate 1
      06-20-2018, 01:00 PM   #16
Thormx331
New Member
0
Rep
10
Posts

Drives: 2003 Z4 e85 2.5i
Join Date: Feb 2018
Location: new york

iTrader: (0)

I haven't tried either as I've only driven this for about a month and still has functions and buttons I'm unaware of, like this trick. I just want to be able to do this incase I have this issue, then I can just get the top down and grab the handle from the inside in a tight situation. I think I read somewhere on her and the manual about the key in the door to put the top down. But with holding the button on the keyfob, on here someone said it was only on 04 and up Z4s, I have an 03. When I get the new actuator in from ECS ill give both a try.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:27 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST