ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Navigation, Audio, Bluetooth, Stereo, Electronics Talk
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      06-29-2023, 01:56 PM   #1
wyshyvanuk
Second Lieutenant
United_States
430
Rep
225
Posts

Drives: 2008 Z4 MR
Join Date: Apr 2018
Location: Tucson AZ

iTrader: (0)

CD Cooler Hose

There's a cooler hose shown on RealOEM and, in fact, installed in my 2008 Z4M. See part# 64216984739. The entrance to the hose looks like it is attached to the cockpit side of the firewall. The exit is positioned to blow over the dash mounted CD player (my Business Radio is out of the dash for repair). Does this cooler hose carry AC cooled air, or just "fresh" air from I-don't-know-where? My CD player was refusing to play or eject CDs, and I live in Toasty Tucson. Thanks for any insight.
Ted
Appreciate 0
      07-02-2023, 02:12 AM   #2
XMetal
Colonel
XMetal's Avatar
United_States
1094
Rep
2,836
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2008 Z4M Coupe  [10.00]
2018 Audi S3  [0.00]
2004 X5  [8.50]
I had my radio and vent off for a couple of weeks and am too curios to find out what that hose does. I don't feel any air coming out of it...so not sure what it actually does. I'm assuming that you're referring to the hose circled in red?

My CD player was also refusing to play or eject CDs, but only intermittently. I had mine in for repair with the CD pickup assembly replaced with only slight improvement. It still does it once in a while, but less often than before the repair...so there's still something else that's going on. Where did you sent yours in for repair?
Attached Images
 
__________________
Appreciate 0
      07-02-2023, 09:33 AM   #3
wyshyvanuk
Second Lieutenant
United_States
430
Rep
225
Posts

Drives: 2008 Z4 MR
Join Date: Apr 2018
Location: Tucson AZ

iTrader: (0)

Yep, that's the "cooler" hose.
Just received a replacement for my head unit, with a one year warranty, from Hi-Tech Electronics, 7049 Valjean Ave, Van Nuys, CA 91406 (www.hitechsrrv.com), 818-785-8085. Apparently, a better deal for them than trying to diagnose mine, or it may have been an issue of parts availability. I'll install the replacement this morning.
I haven't checked for air, cool or otherwise, from the hose yet. Once the head unit is back in, I'll block off the center vent and see if any air erupts from the hose. FWIW, a trusted BMW Parts source reports no new radios available, worldwide. Puerto Rico had shown one, but it was "in error".
I did an internet search for Part# 65129205279. Some hits for refurbished (considerably more expensive), but by that time, my replacement was on the way back.
Also, I had ordered and received from BMW, a new center vent. The foam on mine was nasty and one of my clips was partially broken. The foam on the new one was dried out and falling apart. Back it went, and I repaired my old one.
I'll report back after the unit is installed.
Ted
Appreciate 1
XMetal1093.50
      07-02-2023, 11:02 AM   #4
XMetal
Colonel
XMetal's Avatar
United_States
1094
Rep
2,836
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2008 Z4M Coupe  [10.00]
2018 Audi S3  [0.00]
2004 X5  [8.50]
You got very lucky that Hi-Tech Electronics has a replacement head unit for a "reasonable" price and I wished they had offered that to me back then when I sent mine into them for repair. They couldn't duplicate my issue since it was intermittent and offered to replace the entire CD drive tray, but it didn't completely fixed the problem. I had tried finding a replacement, but it was uber expensive even for used one on ebay. I'd found an equivalent one and works quite well, but it couldn't play MP3. I ultimately just returned that one and stuck with my original radio since I know I have a new CD tray in it vs an unknown one on the used.

My vent had the same issues when I had it apart last time. I didn't want to buy a new one since it would just end up with the same faith. After reading your experience with the brand new vent, I'm glad I had decided to give it a go at repairing it. The foam is super cheap on Amazon!

Here's a link to my thread asking for glue recommendation for gluing down the tabs/clips => https://www.zpost.com/forums/showthr...ht=center+vent

Here's the foam I bought from Amazon - fits perfectly => https://www.amazon.com/dp/B00005202U...t_details&th=1
__________________
Appreciate 0
      07-02-2023, 12:21 PM   #5
wyshyvanuk
Second Lieutenant
United_States
430
Rep
225
Posts

Drives: 2008 Z4 MR
Join Date: Apr 2018
Location: Tucson AZ

iTrader: (0)

Same Solution

Well, this is cosmic:
JB Weld Plastic Bonder and Amazon's Yotache Gray Foam Weather Stripping Tape 2 Rolls 3/8 Inch Wide X 1/4 Inch Thick. First photo is the "new" vent with the foam falling off.
Attached Images
   
Appreciate 0
      07-02-2023, 12:51 PM   #6
wyshyvanuk
Second Lieutenant
United_States
430
Rep
225
Posts

Drives: 2008 Z4 MR
Join Date: Apr 2018
Location: Tucson AZ

iTrader: (0)

Cooler Hose Test

I blocked off the center vent , and fount that air was blowing from the cooler hose, both with the air conditioning on and off. So much for my theory that the issue with the CD player was temperature related. Happens both with the top up and top down.
Appreciate 1
XMetal1093.50
      07-02-2023, 01:40 PM   #7
XMetal
Colonel
XMetal's Avatar
United_States
1094
Rep
2,836
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2008 Z4M Coupe  [10.00]
2018 Audi S3  [0.00]
2004 X5  [8.50]
Quote:
Originally Posted by wyshyvanuk View Post
I blocked off the center vent , and fount that air was blowing from the cooler hose, both with the air conditioning on and off. So much for my theory that the issue with the CD player was temperature related. Happens both with the top up and top down.
Maybe the reason why I didn't felt anything was because I didn't block off the vents when I tried feeling for air there My radio hasn't act up recently, so I suppose the hose is doing it's job?
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:09 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST