ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-21-2019, 06:36 PM   #1
RonnieJ
New Member
2
Rep
5
Posts

Drives: 2003 BMW Z4
Join Date: Apr 2019
Location: Sterling Heights MI

iTrader: (0)

warning lights

Hello all, I have a 2003 Z4 2.5 which I bought a month past. Today when I was driving the Brake warning light came on then the DSC light and the Air Bag warning light. When I bought it I noticed the rear brake pads had been changed but not the front and I was getting a chirping sound from them today. Could the front pads cause all of these to come on?
Appreciate 0
      05-22-2019, 08:45 PM   #2
Clearancediver
Private First Class
12
Rep
166
Posts

Drives: 2004 Z4
Join Date: Oct 2012
Location: Victoria, BC Canada

iTrader: (0)

Google Z4 trifecta....lots of info regarding these lights/issue....

Check your alternator voltage output...battery voltage in the morning before starting. Low voltage is a no no for these cars.
__________________
Sent from my smart phone...
Appreciate 0
      05-23-2019, 04:45 PM   #3
unluky
Captain
unluky's Avatar
219
Rep
798
Posts

Drives: 04 z4 3.0 Sport & 15 X5 35i XD
Join Date: Aug 2013
Location: Sedalia, MO

iTrader: (0)

Garage List
Quote:
Originally Posted by Clearancediver View Post
Google Z4 trifecta....lots of info regarding these lights/issue....

Check your alternator voltage output...battery voltage in the morning before starting. Low voltage is a no no for these cars.
I'll 2nd this - just went through tracking this down this winter. Lights will keep getting worse and more of them. Finally tested the voltage at the battery and found out my Alternator and/or voltage regulator was out. Replaced them both and back to full strength again.
__________________


2015 X5 XDrive 35i - 2004 Z4 3.0 Sport
Appreciate 0
      05-23-2019, 07:06 PM   #4
RonnieJ
New Member
2
Rep
5
Posts

Drives: 2003 BMW Z4
Join Date: Apr 2019
Location: Sterling Heights MI

iTrader: (0)

Quote:
Originally Posted by unluky View Post
I'll 2nd this - just went through tracking this down this winter. Lights will keep getting worse and more of them. Finally tested the voltage at the battery and found out my Alternator and/or voltage regulator was out. Replaced them both and back to full strength again.
Thank you both for your help.
Appreciate 1
unluky219.00

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:53 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST