ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Navigation, Audio, Bluetooth, Stereo, Electronics Talk
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      06-06-2017, 07:09 AM   #1
elwesso
Second Lieutenant
elwesso's Avatar
17
Rep
299
Posts

Drives: Z4 M Coupe
Join Date: Dec 2012
Location: Indiana

iTrader: (1)

Aux port replacement/iPhone cable

The Aux port on my M coupe has started to turn really flaky. When you plug it in all the way, I only get sound out of one speaker, but you can usually finagle it to get it to kind of work. I've tried 2 or 3 cables and that's definitely not the issue (plugged them into other things and they work fine), so I figure I just need to replace the aux port (no biggie).

Typically I am using my phone with pandora/etc to listen to music, and historically I've just plugged the phone and charger in and I'm good to go. I recently upgraded to the iPhone 7, which we all know does not have a headphone jack, so I can't charge and listen to music easily (without buying additional stuff).

Did a little bit of searching around, and I've seen these cables on eBay that have an Aux cable and iPhone plug which would allow me to do exactly what I'm after. Seeing how I have to replace the Aux port anyway, I figured this would be a nice upgrade/replacement, but curious if anyone has tried this or something like it?

http://www.ebay.com/itm/Car-AUX-Audi...dWsXwK&vxp=mtr
__________________
- Wes
2007 BMW M Coupe
2016 VW GTI
Appreciate 0
      06-13-2017, 03:26 PM   #2
MeisterS
Rennfahrer
MeisterS's Avatar
16
Rep
125
Posts

Drives: E85 M
Join Date: Mar 2015
Location: Motorcity

iTrader: (0)

Not sure where you plan an outlet for the 2 ends once its connected to the back of your radio unit. May have to drill holes in the plastic trim cover below the radio.
I was in the same boat sometime last year. Aux went bust and was tired of messing around with 2 wires for music and charging.
I bought this: BMW part# 82110149390 which is the cable itself and does not include the tray. Plug in a good Aux- bluetooth adapter and you have 1 less wire to use. Can always use the car charger as and when needed. Goodluck
__________________

Z4M-R |Dinan Pedals|CDV Delete|K&N|BBS-LM(Reps) on Michelin PSS|
Hers'- '06 E90 325xi
'98 Accord V6 Coupe| Sold

Z4-3.0si |Sold
Appreciate 0
      11-20-2017, 09:56 PM   #3
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1134
Rep
11,336
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (88)

Garage List
For longest time I looked for a Bluetooth adapter that

1) runs off USB power
2) has 1/8" audio input
3) pairs automatically
4) decent sound quality

Only thing that met all of the above was he HK BTA10. Bought a hardware kit, connected audio to the aux port, and tucked it away under the ash tray. Couldn't be happier, connects to my phone every time in few seconds and sound quality is clear and loud. No more hassle of dealing with audio cables...


__________________
Appreciate 2
      05-03-2018, 12:18 PM   #4
Waoudi
Private First Class
Waoudi's Avatar
United_States
16
Rep
172
Posts

Drives: '17 X5 MSport, '16 M3 ZCP
Join Date: Dec 2006
Location: Nashville, TN

iTrader: (0)

Quote:
Originally Posted by 3002 tii View Post
For longest time I looked for a Bluetooth adapter that

1) runs off USB power
2) has 1/8" audio input
3) pairs automatically
4) decent sound quality

Only thing that met all of the above was he HK BTA10. Bought a hardware kit, connected audio to the aux port, and tucked it away under the ash tray. Couldn't be happier, connects to my phone every time in few seconds and sound quality is clear and loud. No more hassle of dealing with audio cables...


Any chance you have a DIY? I have the mpow and it sucks! Does the hardware kit allow to connect to car power?
Appreciate 0
      05-03-2018, 01:27 PM   #5
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1134
Rep
11,336
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (88)

Garage List
Quote:
Originally Posted by Waoudi View Post
Any chance you have a DIY? I have the mpow and it sucks! Does the hardware kit allow to connect to car power?
No DIY but no different than any hardwire DIY for our cars. Just get an add a fuse kit and hardwire kit like this

https://www.amazon.com/dp/B007O59Z7I..._Fj16AbPSVWDC5

Going off memory here:

1. Take the ash tray out (comes out with 1 screw, look on YouTube for Z4 audio upgrade DIY’s)

2. Once that’s out, I think you can reach inside and stuff the HK BTA underneath towards the right side, above the shifter

3. Take off lower trim panel underneath the hvac controls

4. Disconnect the aux piece from that trim panel and connect a 1/8” audio cable from the HK BTA to the aux port. You should be able to fish the aux cable easily down to the ash tray area.

5. Connect the hardwire kit to the HK BTA (micro usb) and run it down the passenger side of the trans tunnel, underneath the plastic trim.

6. Pull it out and run it up along the glove box. Then crimp the add a fuse to the wire ends of the hardwire kit.

7. Open glove box, access the fuse box and find the appropriate fuse (do quick search here to see what others did for a radar detector) and location for ground.
__________________
Appreciate 0
      05-19-2018, 02:59 PM   #6
ShawnPaul
Private First Class
ShawnPaul's Avatar
Canada
91
Rep
176
Posts

Drives: 2007 Z4M Coupe
Join Date: May 2018
Location: Mississauga

iTrader: (0)

Any pics of what this looks like? I want to find a solution for my car where I don't see any wires.

And the unit you keep where again? Was difficult to picture where you put it.

The unit seems like it's exactly the function I want! Thanks for posting.
Appreciate 0
      05-22-2018, 10:11 PM   #7
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1134
Rep
11,336
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (88)

Garage List
Quote:
Originally Posted by ShawnPaul View Post
Any pics of what this looks like? I want to find a solution for my car where I don't see any wires.

And the unit you keep where again? Was difficult to picture where you put it.

The unit seems like it's exactly the function I want! Thanks for posting.
Not sure what pics youíd want to see because once itís hooked up you donít see anything. The device is installed under the center console trim.
__________________
Appreciate 1
      05-24-2018, 09:09 AM   #8
ShawnPaul
Private First Class
ShawnPaul's Avatar
Canada
91
Rep
176
Posts

Drives: 2007 Z4M Coupe
Join Date: May 2018
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by 3002 tii View Post
Quote:
Originally Posted by ShawnPaul View Post
Any pics of what this looks like? I want to find a solution for my car where I don't see any wires.

And the unit you keep where again? Was difficult to picture where you put it.

The unit seems like it's exactly the function I want! Thanks for posting.
Not sure what pics you’d want to see because once it’s hooked up you don’t see anything. The device is installed under the center console trim.
Quote:
Originally Posted by 3002 tii View Post
Quote:
Originally Posted by ShawnPaul View Post
Any pics of what this looks like? I want to find a solution for my car where I don't see any wires.

And the unit you keep where again? Was difficult to picture where you put it.

The unit seems like it's exactly the function I want! Thanks for posting.
Not sure what pics you'd want to see because once it's hooked up you don't see anything. The device is installed under the center console trim.

Oh, I get it now. Thought you had everything visible. Ok thanks.
Appreciate 0
      05-24-2018, 11:28 AM   #9
3002 tii
Lieutenant General
3002 tii's Avatar
United_States
1134
Rep
11,336
Posts

Drives: Z4M, X3 35i, i3 REx
Join Date: Apr 2008
Location: CT

iTrader: (88)

Garage List
Quote:
Originally Posted by ShawnPaul View Post
Oh, I get it now. Thought you had everything visible. Ok thanks.
Tell you what, give me few days and Iíll try to take couple pics showing how youíd install it.
__________________
Appreciate 1
      05-24-2018, 04:21 PM   #10
ShawnPaul
Private First Class
ShawnPaul's Avatar
Canada
91
Rep
176
Posts

Drives: 2007 Z4M Coupe
Join Date: May 2018
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by 3002 tii View Post
Quote:
Originally Posted by ShawnPaul View Post
Oh, I get it now. Thought you had everything visible. Ok thanks.
Tell you what, give me few days and I'll try to take couple pics showing how you'd install it.
Thanks a lot 3002 tii
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:43 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST