ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Navigation, Audio, Bluetooth, Stereo, Electronics Talk
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      08-08-2013, 11:25 PM   #1
XMetal
Colonel
XMetal's Avatar
United_States
502
Rep
2,339
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2018 Audi S3  [0.00]
2008 Z4M Coupe  [0.00]
2004 X5  [3.50]
GROM Audio USB interface installed

After a few email exchanges with GROM Audio, we still cannot verified whether their BMW/Mini USB adapter (GROM-USB2P-BMWT) would work on my '08 MCoupe as their website have our cars listed as having the MOST bus, which isn't true. Also, I wasn't sure if I needed their DSP adapter either. Since they have a 30-days return policy, I decided to give it a shot and just ordered the unit by itself without the DSP adapter. As expected, it worked, but not without a few minor bugs.

Installation was quite straight forward. After taking the rear covers apart, I spent the most time looking for the 3 & 6-pins connectors. Found them taped to the body of the car behind the AMP, which is where I ended up stashing the GROM unit. My car has DSP, but it worked without needing their DSP adapter. The unit did come with a USB extension cable, but I found a Logitech extension cable that had a nice base, which provided a good surface for taping it to the console area. The extension cable was fed through an access hole under the center console by removing the breakout tab.

The 32G flash drive will provide enough music that I don't think I will hear a repeated song for quite some time. Music is organized by making 6 main folders - 1 for each "CD". You can have as many subfolders as you wish, the unit will just flatten them all out.

The unit isn't perfect...so now comes the bug list:
  1. Out of the box, you can't select "CD6". Pushing the "6" button will bring up an option menu, which is similar to pressing the "SEL" button, but presented in a slightly different format plus a few more features. This bug can be somewhat patched by using a config file (to disable auto 16:9 NAV detect) placed on the root directory of the USB drive. Now, I can play the content of "CD6", but the unit still thinks "CD1" is selected...if that makes sense (take a look at the provided picture, and you'll understand - the content of "CD6" is being played, but still showed CD1 as selected).
  2. If you don't exit a menu a certain way, some of the button will no longer function correctly. When this happens, you'll have to select AM/FM, then MODE to get back into USB and everything will work again.

A Minor gripe about the text display...it's horrible as it can only display 10 characters and it toggles back & forth between Artist & Title. I'm hoping that GROM can correct this so it will display MP3 tags similar to the OE CD Player.

I've reported these minor bugs to GROM, and hopefully, they can provide a cure for them. Overall, I'm very pleased with the unit.
Attached Images
    

Last edited by XMetal; 08-08-2013 at 11:36 PM..
Appreciate 0
      03-25-2018, 05:09 PM   #2
SDMCoupe
Private
20
Rep
84
Posts

Drives: 2007 BMW Z4M Coupe - Imola Red
Join Date: Oct 2015
Location: San Diego

iTrader: (0)

I know this is an old post, but I wanted to thank you for it. I was struggling with this install since GROM insisted i needed the DSP adapter. I couldn't get any audio for the life of me to work with the DSP adaptor. I stumbled across your post and tossed the DSP adaptor. What do you know...it all works now. iPhone 6s connects, charges and I get audio from it.

Thanks!!!
Appreciate 0
      03-25-2018, 06:57 PM   #3
XMetal
Colonel
XMetal's Avatar
United_States
502
Rep
2,339
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2018 Audi S3  [0.00]
2008 Z4M Coupe  [0.00]
2004 X5  [3.50]
You're very much welcome. That was my whole point of posting this, is to help others that may want to add this "feature" to our archaic infotainment system. Do you have NAV? If so, I was wondering if GROM had fixed some of my gripes?
Appreciate 0
      03-26-2018, 12:48 AM   #4
SDMCoupe
Private
20
Rep
84
Posts

Drives: 2007 BMW Z4M Coupe - Imola Red
Join Date: Oct 2015
Location: San Diego

iTrader: (0)

Yes I have NAV. I just got it to work and haven't played much with it yet. I'll let you know once I do.
Appreciate 0
      03-26-2018, 09:55 AM   #5
koruptor
Private First Class
koruptor's Avatar
United_States
19
Rep
148
Posts

Drives: 2008 Z4 3.0si Coupe
Join Date: Feb 2015
Location: Los Angeles, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by XMetal View Post
You're very much welcome. That was my whole point of posting this, is to help others that may want to add this "feature" to our archaic infotainment system. Do you have NAV? If so, I was wondering if GROM had fixed some of my gripes?
I have the USB3 unit and can confirm the 10 character limit for songs is still there. It's unfortunate GROM has not updated that.
__________________
2008 Z4 3.0si Coupe
Appreciate 0
      03-26-2018, 01:10 PM   #6
The HACK
Midlife Crises Racing Gold Chain Class
The HACK's Avatar
1516
Rep
5,211
Posts

Drives: 2006 MZ4C, 2017 Corvette GS
Join Date: Oct 2007
Location: Welcome to Jamaica have a nice day

iTrader: (1)

Lifesaver! XMetal you rock, and thank you SDMCoupe for bumping this up.

I just received my GROM trunk unit and realized what I probably wanted to install was the GROM behind dash, because originally I didn't think I'd be able to run the cable through to the front. This literally popped up at just the right time.
__________________
Sitting on a beat-up office chair in front of a 5 year old computer in a basement floor, sipping on stale coffee watching a bunch of meaningless numbers scrolling aimlessly on a dimly lit 19” monitor.
Appreciate 0
      05-19-2018, 02:52 PM   #7
ShawnPaul
Private First Class
ShawnPaul's Avatar
Canada
91
Rep
177
Posts

Drives: 2007 Z4M Coupe
Join Date: May 2018
Location: Mississauga

iTrader: (0)

I am also thinking about getting this unit for my m coupe. I don't have the cd changer pictured and don't have NAV. Do I need those for this system to work?

And the USB cord you have coming out of it can be used for an Apple charge cord right? Info online about this product seems vague. Any guidance would be greatly appreciated.
Appreciate 0
      05-19-2018, 03:48 PM   #8
XMetal
Colonel
XMetal's Avatar
United_States
502
Rep
2,339
Posts

Drives: Anything
Join Date: Apr 2010
Location: SoCal

iTrader: (0)

Garage List
2018 Audi S3  [0.00]
2008 Z4M Coupe  [0.00]
2004 X5  [3.50]
I don't have a CD changer either. The picture you see is the DVD drive for the NAV. You don't need to have NAV. I actually have 2 of these units - one on the Mcoupe, which have NAV and DSP and one for the X5, which does not have NAV nor DSP...it works in both.

I have actually never plugged anything in other than USB thumb drives, so I can't comment on it about charging.
Appreciate 0
      05-19-2018, 05:13 PM   #9
ShawnPaul
Private First Class
ShawnPaul's Avatar
Canada
91
Rep
177
Posts

Drives: 2007 Z4M Coupe
Join Date: May 2018
Location: Mississauga

iTrader: (0)

Quote:
Originally Posted by XMetal View Post
I don't have a CD changer either. The picture you see is the DVD drive for the NAV. You don't need to have NAV. I actually have 2 of these units - one on the Mcoupe, which have NAV and DSP and one for the X5, which does not have NAV nor DSP...it works in both.

I have actually never plugged anything in other than USB thumb drives, so I can't comment on it about charging.
Thanks for the info. I will look into this, as well as the HK Bluetooth.
Appreciate 0
      05-19-2018, 07:22 PM   #10
The HACK
Midlife Crises Racing Gold Chain Class
The HACK's Avatar
1516
Rep
5,211
Posts

Drives: 2006 MZ4C, 2017 Corvette GS
Join Date: Oct 2007
Location: Welcome to Jamaica have a nice day

iTrader: (1)

It charges my iPhone X just fine. Slow, but it charges.
__________________
Sitting on a beat-up office chair in front of a 5 year old computer in a basement floor, sipping on stale coffee watching a bunch of meaningless numbers scrolling aimlessly on a dimly lit 19” monitor.
Appreciate 1
      06-03-2018, 08:10 PM   #11
RobMCoupe
Captain
RobMCoupe's Avatar
54
Rep
916
Posts

Drives: 2007 Z4 M Coupe
Join Date: Feb 2010
Location: Bay Area

iTrader: (6)

A little late for me. Not sure why I didn't find this. I was looking at Grom and wasn't sure it will work. I end up installing Intravee II. It was a pain removing center console to route cable to front.
Appreciate 0
      06-22-2018, 02:09 PM   #12
unluky
Captain
unluky's Avatar
279
Rep
823
Posts

Drives: 04 z4 3.0 Sport & 15 X5 35i XD
Join Date: Aug 2013
Location: Sedalia, MO

iTrader: (0)

Garage List
One question I have - can you use a thumb drive AND bluetooth? Or does the Bluetooth dongle have to go into the only usb port? I'd like to have my songs on a thumb drive, but have the option to connect my phone when I want to for music or map guidance through the speakers.

Looks like these are more preferred over the Dice units
__________________


2015 X5 XDrive 35i - 2004 Z4 3.0 Sport
Appreciate 0
      06-25-2018, 10:19 AM   #13
koruptor
Private First Class
koruptor's Avatar
United_States
19
Rep
148
Posts

Drives: 2008 Z4 3.0si Coupe
Join Date: Feb 2015
Location: Los Angeles, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by unluky View Post
One question I have - can you use a thumb drive AND bluetooth? Or does the Bluetooth dongle have to go into the only usb port? I'd like to have my songs on a thumb drive, but have the option to connect my phone when I want to for music or map guidance through the speakers.

Looks like these are more preferred over the Dice units
The answer is yes, but with a caveat. You'll notice the Grom USB units have 3 ports: USB, EXT1, EXT2. You can hook up your thumb drive to the USB port. Grom sells a BT dongle and other accessories that attaches to the EXT ports.

Here's a diagram from their site:
__________________
2008 Z4 3.0si Coupe
Appreciate 0
      06-26-2018, 08:18 AM   #14
unluky
Captain
unluky's Avatar
279
Rep
823
Posts

Drives: 04 z4 3.0 Sport & 15 X5 35i XD
Join Date: Aug 2013
Location: Sedalia, MO

iTrader: (0)

Garage List
OK - that makes sense. I can use the thumb and bluetooth at the same time, but can't connect directly to my phones while the thumb is in - which should be fine if I have a bluetooth connection anyway. Sounds like I have a new project to add to the list.
__________________


2015 X5 XDrive 35i - 2004 Z4 3.0 Sport
Appreciate 0
      07-31-2018, 07:12 PM   #15
unluky
Captain
unluky's Avatar
279
Rep
823
Posts

Drives: 04 z4 3.0 Sport & 15 X5 35i XD
Join Date: Aug 2013
Location: Sedalia, MO

iTrader: (0)

Garage List
OK - so update for anyone wanting to do this - if you have an earlier E85 with a DSP system - good chance you will need the adapter. Before you order (unlike me) pull your carpet up and look for your connectors. If instead of a 3 pin and 6 pin connector like above....if you have a 3 pin and a coax - you will need to adapter to make this work. I have no 6 pin at all and after lots of searching - I see other with the same issue and why this adapter was made. You also have to tap power and ground with it - so not exactly plug and play like the 3/6 pin set up. Since my amp is in the battery well, I am not sure where I am going to tap acc power from, but I can either run a wire or maybe tap into the BMW assist deal?

I'm sure I'll figure it out - but FYI if you are reading this - check your connectors before you buy!
__________________


2015 X5 XDrive 35i - 2004 Z4 3.0 Sport
Appreciate 0
      08-09-2018, 02:34 AM   #16
jm_73
Registered
Sweden
0
Rep
3
Posts

Drives: BMW Z4 3.0i 2003
Join Date: Aug 2018
Location: Sweden

iTrader: (0)

Groom working om Head unit without amp/DSP?

Hello!

I have a 2003 Z4 with the "Navigation system professional". 6 speaker setup with no amp or DSP. Will the Groom USB still work for me?

Kind regards Jens
Appreciate 0
      08-09-2018, 07:20 PM   #17
koruptor
Private First Class
koruptor's Avatar
United_States
19
Rep
148
Posts

Drives: 2008 Z4 3.0si Coupe
Join Date: Feb 2015
Location: Los Angeles, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by jm_73 View Post
Hello!

I have a 2003 Z4 with the "Navigation system professional". 6 speaker setup with no amp or DSP. Will the Groom USB still work for me?

Kind regards Jens
The GROM will work.
__________________
2008 Z4 3.0si Coupe
Appreciate 0
      11-01-2018, 08:00 PM   #18
KevinC
your average JAMF
KevinC's Avatar
United_States
292
Rep
1,959
Posts

Drives: '08 Z4MC, '16 Golf R
Join Date: Oct 2005
Location: Hereford, AZ

iTrader: (0)

Garage List
I had a BMW CP600 in my original Z4MC. It was pretty cool - connected to the CD changer cable, supports an SD card, similar navigating & display to the Grom unit. But it didn't SOUND good. MP3 tracks played via the CD player sounded very noticeably better at the same bitrate than what came through the CP600. This is the little bugger I'm talking about...

https://www.maintronic.de/en/shop/cp...d-karte-detail

Anyways.. my "new" Z4MC will be here soon and I'm trying to figure out what I'm going to do for tunes. My preference is just to load up a USB stick and slap it in the boot next to a Grom and be done with it. So my question for you guys who have a Grom - how does the USB output sound? Is it equally clean & clear as what you get from the CD player?
__________________
'08 Z4M Coupé LM08602
'16 Golf R
Appreciate 0
      11-01-2018, 10:27 PM   #19
koruptor
Private First Class
koruptor's Avatar
United_States
19
Rep
148
Posts

Drives: 2008 Z4 3.0si Coupe
Join Date: Feb 2015
Location: Los Angeles, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by KevinC View Post
I had a BMW CP600 in my original Z4MC. It was pretty cool - connected to the CD changer cable, supports an SD card, similar navigating & display to the Grom unit. But it didn't SOUND good. MP3 tracks played via the CD player sounded very noticeably better at the same bitrate than what came through the CP600. This is the little bugger I'm talking about...

https://www.maintronic.de/en/shop/cp...d-karte-detail

Anyways.. my "new" Z4MC will be here soon and I'm trying to figure out what I'm going to do for tunes. My preference is just to load up a USB stick and slap it in the boot next to a Grom and be done with it. So my question for you guys who have a Grom - how does the USB output sound? Is it equally clean & clear as what you get from the CD player?
I'm no audiophile, but USB and Bluetooth output sounds fine. CD definitely sounds better and more crisp, but only slightly more. I've never had any complaints about the sound quality on the GROM. Sorry I can't be more descriptive than that.

One thing I'd recommend is if you must play music via USB, put it on a media player like an iPod or MP3 player. The reason is that organizing and navigating a USB flash drive full of music is cumbersome. If there's a playlist or a song you have to play, it's easier to find it on your device than to use the GROM's built-in file navigation via CD changer "discs" (see page 12 of the manual here and you'll know what I mean).
__________________
2008 Z4 3.0si Coupe
Appreciate 0
      11-01-2018, 11:44 PM   #20
KevinC
your average JAMF
KevinC's Avatar
United_States
292
Rep
1,959
Posts

Drives: '08 Z4MC, '16 Golf R
Join Date: Oct 2005
Location: Hereford, AZ

iTrader: (0)

Garage List
Thanks Koruptor. I've read the Grom manual, navigating media is basically the same kludgy process as it was on the CP600. I will simply load up a USB stick with several long playlists and be done with it, so navigation won't be problematic. If I want to hear complete albums or anything not on the stick, I'll just hook up my phone via the aux port and roll that way - but I don't want to fumble with it all the time, hence looking for a Grom-type solution as well.

I could opt to connect something like an old iPod nano, but I don't think there's enough juice to keep it charged. The USB stick solution means I can just leave it there and forget it.
__________________
'08 Z4M Coupé LM08602
'16 Golf R
Appreciate 0
      11-05-2018, 09:00 AM   #21
SDMCoupe
Private
20
Rep
84
Posts

Drives: 2007 BMW Z4M Coupe - Imola Red
Join Date: Oct 2015
Location: San Diego

iTrader: (0)

Has anyone been able to get audio when connected to a Samsung S9+ or similiar? I get audio out of iphone but nothing from the S9. I've updated per Grom's instructions but nothing has worked yet.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:55 AM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST