ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      10-01-2021, 08:16 PM   #1
soundofspeed
New Member
86
Rep
29
Posts

Drives: E36 M3, E86 Z4M, E90 M3
Join Date: Feb 2020
Location: New York / Germany

iTrader: (0)

S54 rough idling - many fault codes

happened from one day to the next.
Was driving perfectly, wanted to start 5 days later. Rough start, lots of misfiring. Didn't recognize the secondary air pump.
Lotīs of error codes popped up:
2A00 - secondary air system
2D06 - DME: mass air system
2F65 - DME: brake booster system check
all the misfiring for the cylinder

it went better after the car got warm.
Cleard all the codaes, after warmup less codes showed up:
2D06 - DME: mass air system
2FDA - DME: crankcase ventilation, system check

and, after driving for a while,
2F65 - DME: brake booster system check

when disconnecting the HFM and the crankcase ventilation valve on top of th engine, the corrospondending electric error codes showed up.

Air fuel ratio adjustment is working. Car has power when driving, don't feel a difference.

With the autel system I was able to turn on the secondary air pump, so connections the the air pump seem to work.

Interesting observation:
When opening the oil filler cap, nothing changes, also AFR adaption doesn't change.
When driving, also mass air flow in kg/h doesn't change, stays constant at 1,1kg/h.

Have to check if secondary air pump starts when engine is cold.

Thanks for all ideas.
Attached Images
  
__________________
Appreciate 0
      10-02-2021, 02:48 PM   #2
Michael9218
First Lieutenant
460
Rep
393
Posts

Drives: 2007 Z4 M Coupe
Join Date: Oct 2012
Location: Woodstock, GA

iTrader: (0)

Possibly the MAF?
Mine recently died on the track car. At first the symptoms were random and infrequent. Rough idle was definitely one of the symptoms.
Mine didn't throw any codes, but a lot of systems have been eliminated from the car and the ECU.
Appreciate 0
      10-04-2021, 09:46 AM   #3
drocket77
Private
United_States
3
Rep
50
Posts

Drives: 2004 BMW Z4
Join Date: Nov 2019
Location: Delaware

iTrader: (0)

I would check MAF first, than O2 sensors. My car did this, as the previous owner had all the O2 sensors before the cat. I "kinda fixed it" with a spark anti fouler for the "rear" O2's. It never threw a code for the O2's, and would have random misfires with the exception of 1 of the cylinders(think it was #1). But now I still get a misfire every now and than, but only when I am at a lower speed with a low constant RPM. I plan on getting this fixed, but do not have an inspection for 1.5 more years. When I get time and more welding skill I will attempt to fix it.
Appreciate 0
      10-04-2021, 12:28 PM   #4
wdb
dances with roads
wdb's Avatar
United_States
2928
Rep
3,502
Posts

Drives: '07 E86, '07 E93, '02 996
Join Date: Jul 2015
Location: the perimeter

iTrader: (4)

Sounds like a vacuum leak.
Appreciate 0
      10-09-2021, 06:12 PM   #5
soundofspeed
New Member
86
Rep
29
Posts

Drives: E36 M3, E86 Z4M, E90 M3
Join Date: Feb 2020
Location: New York / Germany

iTrader: (0)

thank you all for the ideas.
Checked the MAF again, in the MAF only gives a constant value.
Drove to a friend with a Z4M, put in his MAF and it showed values.
Will order a new MAF now.
__________________
Appreciate 0
      10-16-2021, 08:56 PM   #6
soundofspeed
New Member
86
Rep
29
Posts

Drives: E36 M3, E86 Z4M, E90 M3
Join Date: Feb 2020
Location: New York / Germany

iTrader: (0)

put in a new MAF.

Works without problems now.
__________________
Appreciate 1
racerbruce3297.50
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:51 PM.




zpost
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST