ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      04-19-2013, 10:49 AM   #1
bassrebel
The Lazy one...
United_States
3
Rep
182
Posts

 
Drives: Z4 3.0i & E90 330i
Join Date: Mar 2012
Location: Orlando, FL

iTrader: (2)

Carver DSP Amp got wet... how screwed am I?

Hey Guys,

Last week a gallon of water I had on my trunk opened and all the water fell on the amp, now it's not working...

Could there be any fix to it, or would I have to buy a new one?

Thanks
__________________
Follow me on Instragram @bassrebel
2003 BMW z4 3.0i 2006 BMW 330i
Appreciate 0
      04-19-2013, 11:09 AM   #2
thekurgan
Bad Lieutenant
thekurgan's Avatar
United_States
34
Rep
2,891
Posts

 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Check realoem or penskeparts, it is pricy.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BPMSport 91 octane tune/BPMSport Feature coding/BMW Pedals/Dinan Exhaust/Alcantara Wheel/Rear Fog Switch/Rattle fixes
Appreciate 0
      04-19-2013, 01:57 PM   #3
Jroc
First Lieutenant
5
Rep
320
Posts

 
Drives: Mcoupe
Join Date: Sep 2011
Location: United States

iTrader: (0)

See if any other cars use the same amp, you might have to get it recoded. Hopefully it's just the unit and you didn't fry any wires
Appreciate 0
      04-19-2013, 03:15 PM   #4
bassrebel
The Lazy one...
United_States
3
Rep
182
Posts

 
Drives: Z4 3.0i & E90 330i
Join Date: Mar 2012
Location: Orlando, FL

iTrader: (2)

At least I checked and didn't see any fuses blown, so hopefully it wasn't that bad.

Does anyone know which amps can I re-code to be able to use it on my car?
__________________
Follow me on Instragram @bassrebel
2003 BMW z4 3.0i 2006 BMW 330i
Appreciate 0
      04-19-2013, 03:17 PM   #5
bassrebel
The Lazy one...
United_States
3
Rep
182
Posts

 
Drives: Z4 3.0i & E90 330i
Join Date: Mar 2012
Location: Orlando, FL

iTrader: (2)

BTW I have an offer for a RedStar DSP... does anyone know if it's compatible?
__________________
Follow me on Instragram @bassrebel
2003 BMW z4 3.0i 2006 BMW 330i
Appreciate 0
      04-20-2013, 07:53 AM   #6
ssummers
Private First Class
2
Rep
142
Posts

 
Drives: 2005 Z4 3.0
Join Date: Sep 2009
Location: My office

iTrader: (1)

Now would be a good time to replace that crappy stock system....

http://www.zpost.com/forums/showthread.php?t=784148
Appreciate 0
      04-20-2013, 10:56 AM   #7
Jroc
First Lieutenant
5
Rep
320
Posts

 
Drives: Mcoupe
Join Date: Sep 2011
Location: United States

iTrader: (0)

Check xoutpost for any amp questions, those guys are bmw audio gurus
Appreciate 0
      04-20-2013, 11:13 AM   #8
ZStig
Major General
101
Rep
7,244
Posts

 
Drives: VT2-525 M Roadster
Join Date: Jun 2008
Location: Delray Beach, FL

iTrader: (3)

I killed mine with a gallon of paint in the old Z. its dead. Time to check ebay..
__________________
Appreciate 0
      04-21-2013, 09:20 PM   #9
gtMc
Captain
gtMc's Avatar
8
Rep
703
Posts

 
Drives: '08 MC
Join Date: Nov 2011
Location: NNJ

iTrader: (1)

Garage List
'03 e39 m sport  [0.00]
'08 mc  [0.00]
Quote:
Originally Posted by bassrebel View Post
At least I checked and didn't see any fuses blown, so hopefully it wasn't that bad.

Does anyone know which amps can I re-code to be able to use it on my car?
Try an x3 amp. Pretty sure its the same part number as the e85 - e86 amp. Def need to get it recorded tho. Its not a cheap amp. Hopefully someone can sell you a used one.
__________________
ZHP/Zeck CDV/VT engine mounts/RE trans mounts;clutch stop/Stubby
Appreciate 0
      04-22-2013, 12:21 AM   #10
TestShoot
I love guibos
TestShoot's Avatar
United_States
0
Rep
86
Posts

 
Drives: DD=E85 3.0i
Join Date: Jul 2009
Location: Beverly Hills

iTrader: (0)

Send a message via ICQ to TestShoot Send a message via AIM to TestShoot Send a message via Yahoo to TestShoot Send a message via Skype™ to TestShoot
I gave up and am in phase two of my upgrade. Right now I have the AVX77 JVC headunit, and I am shopping for speakers.
__________________
+-============[tSc]==============-+
http://www.TestShoot.com
Appreciate 0
      04-24-2013, 05:40 AM   #11
bassrebel
The Lazy one...
United_States
3
Rep
182
Posts

 
Drives: Z4 3.0i & E90 330i
Join Date: Mar 2012
Location: Orlando, FL

iTrader: (2)

Quote:
Originally Posted by gtMc View Post
Try an x3 amp. Pretty sure its the same part number as the e85 - e86 amp. Def need to get it recorded tho. Its not a cheap amp. Hopefully someone can sell you a used one.
Dies that mean that I can use a different amp (different part number, still from a z4) and get it recoded?
__________________
Follow me on Instragram @bassrebel
2003 BMW z4 3.0i 2006 BMW 330i
Appreciate 0
      04-24-2013, 10:02 PM   #12
gtMc
Captain
gtMc's Avatar
8
Rep
703
Posts

 
Drives: '08 MC
Join Date: Nov 2011
Location: NNJ

iTrader: (1)

Garage List
'03 e39 m sport  [0.00]
'08 mc  [0.00]
Quote:
Originally Posted by bassrebel View Post
Dies that mean that I can use a different amp (different part number, still from a z4) and get it recoded?
Kind of.... iirc, there are 2 part numbers that were use in the z4. It should be the same part number in the x3. Double check them on real oem, or check the thread on amp coding experimental help, we posted them in there.

But if you get the same part number out of an x3, that matches the z4, then you can just recode that to the z4 and you are in great shape.
__________________
ZHP/Zeck CDV/VT engine mounts/RE trans mounts;clutch stop/Stubby
Appreciate 0
      04-25-2013, 06:17 AM   #13
gtMc
Captain
gtMc's Avatar
8
Rep
703
Posts

 
Drives: '08 MC
Join Date: Nov 2011
Location: NNJ

iTrader: (1)

Garage List
'03 e39 m sport  [0.00]
'08 mc  [0.00]
Quote:
Originally Posted by bassrebel View Post
Dies that mean that I can use a different amp (different part number, still from a z4) and get it recoded?
searched this AM on the other thread and found this excerpt with part number in one of my old posts:

My wife has an E83... . . . ....and according to what I've read, one of the 2 model numbers for the amp we have in the e85/e86 (65129125751) is also used in the E83

and found this from the other Amp coding thread from MheavNC:

Got my amp replaced with the updated part # 65129138102.. (replaced #65129125751) These amps work with E83/E85/E86 models with top hi fi systems.. Once the new amp is installed, it has to be coded to your car.. This tells the amp if you have navigation/non navigation and if it is for the X3 or Z4..
__________________
ZHP/Zeck CDV/VT engine mounts/RE trans mounts;clutch stop/Stubby
Appreciate 0
      04-29-2013, 06:10 AM   #14
bassrebel
The Lazy one...
United_States
3
Rep
182
Posts

 
Drives: Z4 3.0i & E90 330i
Join Date: Mar 2012
Location: Orlando, FL

iTrader: (2)

Great info, thanks!!!
__________________
Follow me on Instragram @bassrebel
2003 BMW z4 3.0i 2006 BMW 330i
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:35 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST