ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      01-15-2013, 05:06 PM   #1
GP20
Major
16
Rep
1,203
Posts

 
Drives: Z4M
Join Date: Jan 2007
Location: Canada

iTrader: (4)

Headlight not working intermittently. Need new bulb?

My passenger side headlight has been acting up.

When the car's cold (or somewhat cold), I start the car and turn on the headlights, no issue. But if I turn off the car, and then immediately start the car again and turn on the headlights, the passenger side headlight would not go on intermittently, and there's the bulb warning light in the instrument cluster. If I wait another 5~10 minutes or so, the issue would go away.

Has anyone else experienced the same? Is it something a new bulb will fix? Or is it possibly the wirings or connectors or a software issue?
Appreciate 0
      01-15-2013, 05:11 PM   #2
inTgr8r
Major General
inTgr8r's Avatar
Canada
113
Rep
8,082
Posts

 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

iTrader: (7)

most likely the bulb but could be ballast
To check ballast, switch the R/L ballasts & see if the problem changes sides
__________________
Alpinweiss '07 M Coupe •DKF Section1•RPi GT exhaust•Fabspeed Headers•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•H&R COs + ARBs•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
Appreciate 0
      01-15-2013, 05:20 PM   #3
GP20
Major
16
Rep
1,203
Posts

 
Drives: Z4M
Join Date: Jan 2007
Location: Canada

iTrader: (4)

Quote:
Originally Posted by inTgr8r View Post
most likely the bulb but could be ballast
To check ballast, switch the R/L ballasts & see if the problem changes sides
Good idea! Thanks for the quick reply.

The ballast is the number 3 item in the diagram?

http://realoem.com/bmw/showparts.do?...66&hg=63&fg=05

Appreciate 0
      01-15-2013, 07:09 PM   #4
inTgr8r
Major General
inTgr8r's Avatar
Canada
113
Rep
8,082
Posts

 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

iTrader: (7)

Appreciate 0
      01-16-2013, 09:18 AM   #5
Walkurie
Lieutenant
Walkurie's Avatar
United_States
4
Rep
452
Posts

 
Drives: 06 M Roadster / 99 Jaguar XK8
Join Date: Mar 2010
Location: Surf City, CA

iTrader: (2)

Had the same experience when the car was still under warranty. Dealer fixed it, did not elaborate, but it has been 35k miles since and no further problems.
__________________
Vibra Technics engine mounts / Rogue trans mounts / Stoptech brakes / original owner
Appreciate 0
      01-17-2013, 11:39 AM   #6
tommiegun57
Enlisted Member
tommiegun57's Avatar
0
Rep
30
Posts

 
Drives: Stratus Gray z4 i 07
Join Date: Sep 2010
Location: federal way Wa

iTrader: (0)

Quote:
Originally Posted by GP20 View Post
My passenger side headlight has been acting up.

When the car's cold (or somewhat cold), I start the car and turn on the headlights, no issue. But if I turn off the car, and then immediately start the car again and turn on the headlights, the passenger side headlight would not go on intermittently, and there's the bulb warning light in the instrument cluster. If I wait another 5~10 minutes or so, the issue would go away.

Has anyone else experienced the same? Is it something a new bulb will fix? Or is it possibly the wirings or connectors or a software issue?
Similar problem. Blub replacement fixed. Try switching bulbs( L-R).
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:20 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST