ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      11-21-2012, 01:45 PM   #1
j.wallace
New Member
 
Drives: 04' Z4 3.0i SE
Join Date: Aug 2012
Location: Guildford, UK

Posts: 13
iTrader: (0)

Mystery warning light

I've been getting the oil warning come up in my 04' 3.0se for the past couple months now.

I've been checking the oil regularly (10 mins after a run) and it's at the right level.

Bought the car around 4 months and the previous owner had literally just taken her for the oil service.

Maybe a faulty oil sensor?
j.wallace is offline   United Kingdom
0
Reply With Quote
      11-25-2012, 04:25 PM   #2
j.wallace
New Member
 
Drives: 04' Z4 3.0i SE
Join Date: Aug 2012
Location: Guildford, UK

Posts: 13
iTrader: (0)

bump
j.wallace is offline   United Kingdom
0
Reply With Quote
      11-26-2012, 02:53 AM   #3
Finnegan
Major General
 
Finnegan's Avatar
 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

Posts: 6,270
iTrader: (17)

Not all that familiar with this model/engine. However, this thread might be helpful.
Finnegan is offline   United_States
0
Reply With Quote
      11-26-2012, 01:30 PM   #4
The HACK
Garland Operator 7G
 
The HACK's Avatar
 
Drives: 2006 MZ4C, 2013 Veloster Turbo
Join Date: Oct 2007
Location: Jerry Brown's little tree-huggin' state

Posts: 3,334
iTrader: (1)

Quote:
Originally Posted by j.wallace View Post
Maybe a faulty oil sensor?
It's not uncommon. I had to replace 2 of them on my wife's 323Ci.
__________________
Quote:
No way I'd ever take my BMW to the track.
Quote:
Then why do you have $3,000 worth of suspension mods on your car?
Quote:
...
-Overheard at the last B****rfest.
The HACK is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:20 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST