ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > Marketplace > Classifieds : For Sale / Wanted / Group Buys
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      11-10-2012, 08:36 PM   #1
DaleWA
Private First Class
 
Drives: '11 X3 35i/'12 E92 M3
Join Date: Aug 2006
Location: Seattle, WA

Posts: 100
iTrader: (0)

Odo LED Display Blotches

BIMMERPOST / Classifieds
Asking Price:
None
Item Interest
I looked at an '06 MR today. One of its few faults were what I can best describe as blotches in the odo LED display. At first I thought these discolorations were from overspray of cleaning product or amorall on the clear plastic cover over the gage cluster. When I went to wipe it off that is when I realized it was on the display inside. Has anyone seen this condition or know what it is; and can it be fixed?
Thanks!

DaleWA is offline  
0
Reply With Quote
      11-10-2012, 09:51 PM   #2
mousitch
Dark Sider
 
mousitch's Avatar
 
Drives: 2008 Space Gray Z4MC
Join Date: Jan 2010
Location: Missouri

Posts: 1,722
iTrader: (11)

Garage List
Send a message via Yahoo to mousitch
Maybe condensation marks? Id stay away until I had a COMPLETE history.
__________________


2008 Space Grey M Coupe-RPI Scoop-Gruppe M CAI-Eisenmann Race Cans-RE X-pipe-ECU Remap-H&R Sport springs-Zeck CDV-Stock Gloss black powder coated wheels-LED Tekarbon Angel Eyes Project-Michelin Super Sports-Hardwired Escort 9500ix-BMW CCA Member-ST Louis Chapter
mousitch is offline   United_States
0
Reply With Quote
      11-10-2012, 10:12 PM   #3
inTgr8r
Major General
 
inTgr8r's Avatar
 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

Posts: 7,958
iTrader: (7)

.....someone playing with the mileage?
__________________
Alpinweiss '07 M Coupe •DKF Section1•RPi GT exhaust•Fabspeed Headers•VRS Hyper-Narrow rear wing•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•KW Clubsport•H&R ARBs c/w Turner Adj Links•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
inTgr8r is offline   Canada
0
Reply With Quote
      11-10-2012, 10:34 PM   #4
DaleWA
Private First Class
 
Drives: '11 X3 35i/'12 E92 M3
Join Date: Aug 2006
Location: Seattle, WA

Posts: 100
iTrader: (0)

Hmmm... The blotches are more like liquid splashes on the surface of the LED display, but I can't see how it would get inside the cluster. Could be condensation though, had not thought of that.
The car does have a really clean history and low miles.
This would be something I would have looked at during a PPI.
DaleWA is offline  
0
Reply With Quote
      11-10-2012, 11:06 PM   #5
DaleWA
Private First Class
 
Drives: '11 X3 35i/'12 E92 M3
Join Date: Aug 2006
Location: Seattle, WA

Posts: 100
iTrader: (0)

Sorry about posting in the wrong forum, did not realize the iPhone was in the classifieds section...
DaleWA is offline  
0
Reply With Quote
      11-11-2012, 12:14 AM   #6
psygnosis
Major
 
psygnosis's Avatar
 
Drives: '04 Z4 3.0i Sport
Join Date: Nov 2008
Location: WA

Posts: 1,019
iTrader: (0)

My 2004 has what looks like water marks on the LCD display between the gauges. I would say it's something that's not uncommon.
__________________
Straightaways are for fast cars, Corners are for fast drivers.
psygnosis is offline  
0
Reply With Quote
      11-11-2012, 02:51 PM   #7
Nate4641
Captain
 
Nate4641's Avatar
 
Drives: '07 M Roadster
Join Date: Dec 2011
Location: Africa

Posts: 810
iTrader: (0)

Garage List
http://www.zpost.com/forums/showthread.php?t=278468

I think theres another thread with more info, but that should help out a lot.
__________________
2007 ///M Roadster Interlagos Blue & Dark Beige top over Light Sepang extended leather - 19in Morr VS8.2--RPI exhaust--AFE Intake--DKF Hangers--Vibra Technics Engine Mounts--Cosmos Firewall Braces--BMW Strut Brace--Tekarbon CF Engine Cover--Aero Side Skirts--F10 M5 Knob--LeatherZ Mk4 Armrest--SmartTOP Roof Controller--Zeckhausen Racing CDV--DansDecals Reflector Decals--Clutch Stop--LED Trunk Light--Stubby Antenna
Nate4641 is offline   United_States
0
Reply With Quote
      11-11-2012, 04:20 PM   #8
DaleWA
Private First Class
 
Drives: '11 X3 35i/'12 E92 M3
Join Date: Aug 2006
Location: Seattle, WA

Posts: 100
iTrader: (0)

Nate4641 - thanks for that thread reference. That sure sounds like it may be the problem.
DaleWA is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:32 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST