ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      07-19-2012, 03:28 PM   #265
ncnmra
Private First Class
ncnmra's Avatar
Canada
2
Rep
156
Posts

Drives: 2006 M Roadster
Join Date: Jul 2012
Location: Canada

iTrader: (0)

Quote:
Originally Posted by inTgr8r View Post
An ECU 'tune' will overwrite anything in there.
It will overwrite the entire firmware, or the calibration parameters? Sorry if that's a dumb question...I'm used to products having upgradable firmware, but also calibration data sections (I'm an electrical engineer, and we design such products). Do these cars even have a "firmware"?

My impression was that the ECU tune changes the "settings" (ie: timing, fuel ratio, etc), but not the core "program". (That's why you have to send your ECU data to the tuner).

I talked to my local BMW dealership, and they suggested that the ECU does "not" have any factory updates....I'm not sure they understood my question, or if I'm phrasing it properly.
Appreciate 0
      07-19-2012, 03:47 PM   #266
SCHMOUPE
Lieutenant Colonel
SCHMOUPE's Avatar
United_States
17
Rep
1,626
Posts

Drives: 2007 Z4M Coupe
Join Date: Apr 2010
Location: NJ

iTrader: (6)

Garage List
2007 Z4M Coupe  [0.00]
Quote:
Originally Posted by Imran@Evolve View Post
Plenty of customers with E46 M3, E39 M5 and E92 M3's that can testify that we have done this on their cars. We haven't done it on the Z4M yet but don't see any reason why we won't be able to do it.
That would be ideal but I need to see results!!!! If I see that, I can guarantee more than a handful would jump on this tune including myself and a local member as well who has had nothing but trouble with ESS
__________________
The Raspinator

Gruppe M CAI / Euro Headers / Rogue Engineering X-pipe / RE Diablo Exhaust
Appreciate 0
      07-22-2012, 09:12 PM   #267
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

guys with headers (no primary cats)...have your SES lights gone away with the tune? mine's still on.
__________________
'07 MCoupe
lots of mods
Appreciate 0
      07-22-2012, 09:31 PM   #268
txz4
Major
txz4's Avatar
19
Rep
1,098
Posts

Drives: 2006 M coupe
Join Date: Oct 2010
Location: san antonio, texas

iTrader: (3)

Quote:
Originally Posted by zubydafa View Post
guys with headers (no primary cats)...have your SES lights gone away with the tune? mine's still on.
your o2s still need to be connected. I assume they just turn the signal down to almost nothing.
Appreciate 0
      07-23-2012, 12:43 AM   #269
marinb
First Lieutenant
marinb's Avatar
United_States
4
Rep
329
Posts

Drives: 2009 X5 35d
Join Date: Jan 2011
Location: Cupertino, CA

iTrader: (4)

Quote:
Originally Posted by zubydafa View Post
guys with headers (no primary cats)...have your SES lights gone away with the tune? mine's still on.
Did you try clearing the codes after installing the tune?
Appreciate 0
      07-23-2012, 08:21 AM   #270
AUTOX08MC
Enlisted Member
AUTOX08MC's Avatar
0
Rep
37
Posts

Drives: 08 Z4m Coupe
Join Date: May 2011
Location: Indianapolis

iTrader: (0)

My first tune from Evolve resulted in a code of 29F4 and SES light...after an email to Sal I received an updated tune....250 miles later and after two autocrosses....no codes and no SES lights. All four of my 02 sensors are connected to my Fabspeed headers
__________________
08 Z4 MC, Arctic White, GC Suspension 650/800, GC Swaybars (med/soft), Remus Cans, SS Lines, BMW Strut Brace, TC Cline RTAB, RPI Scoop, Stock Wheels w/ Dunlop Star Specs 245/275, Autocross Wheels: Apex 18x9.5 18x10 all w/285/30 A6 Hoosiers, Fabspeed Headers, Evolve Tune, Aluminum Adjustable Rear Camber Arms
Appreciate 0
      07-23-2012, 01:12 PM   #271
beta
Lieutenant Colonel
28
Rep
1,655
Posts

Drives: 2006 M Roadster
Join Date: Mar 2011
Location: CA

iTrader: (2)

That makes sense. If all four connectors are on the headers, then 29F4 code is correct in that you don't have cats installed (at least not for the purposes of monitoring). So you likely got a second tune with the "cat less O2 ready" option. Did you request that option originally?
__________________
Appreciate 0
      07-23-2012, 02:21 PM   #272
krnnerdboy
Colonel
krnnerdboy's Avatar
United_States
39
Rep
2,217
Posts

Drives: v10 m6
Join Date: Nov 2008
Location: so cal

iTrader: (10)

for anyone on the fence, I wouldn't hesitate to recommend an evolve tune for any car. Just got mine done on my m6 and the gains and top end is very noticeable! And the customer service is top notch...something you wouldn't assume considering the recent success evolve has been having with so many group buys exploding. My communications with Sal and the vendor made me feel like I was their only customer
__________________

F80 m3, 997 gt3, 14 ram ctd, f15 x5, drz400sm

Gone:z4m, boss 302, c6 z06, m6,z3m
Appreciate 0
      07-23-2012, 03:06 PM   #273
AUTOX08MC
Enlisted Member
AUTOX08MC's Avatar
0
Rep
37
Posts

Drives: 08 Z4m Coupe
Join Date: May 2011
Location: Indianapolis

iTrader: (0)

Quote:
Originally Posted by beta View Post
That makes sense. If all four connectors are on the headers, then 29F4 code is correct in that you don't have cats installed (at least not for the purposes of monitoring). So you likely got a second tune with the "cat less O2 ready" option. Did you request that option originally?
Truth is... I am not sure... although I did state which mods were done to the car when I sent in the original download from my car. Regardless, when notified of the code and the SES light Sal had a new tune in my hands within 24 hours and since then I have had no problems, and the car really does run well.
__________________
08 Z4 MC, Arctic White, GC Suspension 650/800, GC Swaybars (med/soft), Remus Cans, SS Lines, BMW Strut Brace, TC Cline RTAB, RPI Scoop, Stock Wheels w/ Dunlop Star Specs 245/275, Autocross Wheels: Apex 18x9.5 18x10 all w/285/30 A6 Hoosiers, Fabspeed Headers, Evolve Tune, Aluminum Adjustable Rear Camber Arms
Appreciate 0
      07-25-2012, 09:09 AM   #274
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

Quote:
Originally Posted by marinb View Post
Did you try clearing the codes after installing the tune?
codes cleared...but SES comes back on. i'll contact evolve for help.

@ everybody: the tune is phenomenal! i have the before dyno and will get an after dyno in next week or so to see some evidence.
__________________
'07 MCoupe
lots of mods

Last edited by zubydafa; 07-26-2012 at 10:02 PM.
Appreciate 0
      08-01-2012, 11:52 AM   #275
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

just a little update: code 29F4 gone...no codes for over a hundred miles so we're good.

I'm going for a post dyno tomorrow and can report on actual gains.
__________________
'07 MCoupe
lots of mods
Appreciate 0
      08-01-2012, 06:56 PM   #276
Jumbosock
Captain
Jumbosock's Avatar
13
Rep
838
Posts

Drives: 2007 M coupe
Join Date: Apr 2011
Location: San Diego

iTrader: (0)

Yes please report your graphs! It'll be nice to see those!
Appreciate 0
      08-02-2012, 08:23 AM   #277
Blind32
Certified Adrenaline Junkie
Blind32's Avatar
United_States
16
Rep
1,318
Posts

Drives: '07 Z4MC
Join Date: Sep 2009
Location: Dallas TX

iTrader: (2)

Send a message via AIM to Blind32 Send a message via Yahoo to Blind32
I have a pre headers dyno, post headers dyno but I do not have a post Headers + tune dyno. Temps in Texas are around 111* F now and the other 2 dynos were done around 85-90. Going to wait until it cools off a bit before I get the next dyno.
Appreciate 0
      08-10-2012, 01:02 AM   #278
OG_M3
First Lieutenant
United_States
3
Rep
315
Posts

Drives: 1985 AE86 & E92 SG M3
Join Date: Mar 2008
Location: Vegas

iTrader: (2)

Garage List
2011 BMW M3  [0.00]
2007 BMW Z4MC  [0.00]
1985 AE86  [0.00]
Quote:
Originally Posted by zubydafa View Post
just a little update: code 29F4 gone...no codes for over a hundred miles so we're good.

I'm going for a post dyno tomorrow and can report on actual gains.
any news ?
Appreciate 0
      08-10-2012, 07:16 PM   #279
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

Quote:
Originally Posted by OG_M3 View Post
any news ?
yeaaaa

so in typical forum fashion, I haven't gone yet. I have an appointment for Wednesday next week..let's see if I can keep that one haha
__________________
'07 MCoupe
lots of mods
Appreciate 0
      08-10-2012, 09:31 PM   #280
Jumbosock
Captain
Jumbosock's Avatar
13
Rep
838
Posts

Drives: 2007 M coupe
Join Date: Apr 2011
Location: San Diego

iTrader: (0)

Quote:
Originally Posted by zubydafa View Post
yeaaaa

so in typical forum fashion, I haven't gone yet.
Yeah most of us have lives outside of our cars. I have a huge bin of parts and list of things I still need to do!! Thinking about taking a staycation just to work on my car so I can get some dynos done!
Appreciate 0
      08-17-2012, 09:08 AM   #281
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

SOS

I have inspection due this month and am at the shop right now. I passed inspection but they can't do emissions because it's in a not ready mode? Like it didn't fail but they can't do anything because it's reading not ready. I thought the tune was supposed to let you pass emissions...

Not sure what to do
__________________
'07 MCoupe
lots of mods
Appreciate 0
      08-17-2012, 09:30 AM   #282
flipm3
E46 + E90
Philippines
43
Rep
2,797
Posts

Drives: E46 M3 + E90 M3
Join Date: Jul 2008
Location: Illinois

iTrader: (1)

Garage List
2009 BMW M3  [0.00]
2002 BMW M3  [0.00]
Quote:
Originally Posted by zubydafa View Post
SOS

I have inspection due this month and am at the shop right now. I passed inspection but they can't do emissions because it's in a not ready mode? Like it didn't fail but they can't do anything because it's reading not ready. I thought the tune was supposed to let you pass emissions...

Not sure what to do
Provided you received the tune as ordered, your car needs to go through a full proper "drive cycle" to make sure all sensors are tested for and in ready state.

These DMEs are a bit tricky since depending on how you drive, what time of speed, length of time, interval, etc...will really determine when your car is in ready state.

For example, when I was 100% catless, it took my car literally near 1000 miles to finally register I had no cats. Another time when I switched to another set of catless headers, it took just a couple hundred. So you can see how much it varies on when your car goes through it's diagnostics.

In the end, this tune can get you to pass to OBDII Readiness. I know of quite a few cases where it has. All in various States, including PA, if my memory serves me right.
__________________
E90 M3 DCT|Melbourne Red . Speed Cloth | My Build Thread
E46 M3 6MT|Jet Black . Black Nappa Leather | My Build Thread
Appreciate 0
      08-17-2012, 11:13 AM   #283
Jumbosock
Captain
Jumbosock's Avatar
13
Rep
838
Posts

Drives: 2007 M coupe
Join Date: Apr 2011
Location: San Diego

iTrader: (0)

Quote:
Originally Posted by zubydafa View Post
SOS

I have inspection due this month and am at the shop right now. I passed inspection but they can't do emissions because it's in a not ready mode? Like it didn't fail but they can't do anything because it's reading not ready. I thought the tune was supposed to let you pass emissions...

Not sure what to do
Certain readiness sensors need specific driving parameters to become ready and can take a long time if you don't meet those parameters while driving. In my E46M3 the kicker was to drive slow on the freeway. I think just under 50mph without oscillating the gas pedal too much. It takes 5 or so miles of this driving. Try not to exceed 50mph.
Appreciate 0
      08-17-2012, 01:14 PM   #284
kennyfrc
First Lieutenant
kennyfrc's Avatar
4
Rep
378
Posts

Drives: 2008 Z4MC
Join Date: Aug 2010
Location: ATL GA

iTrader: (1)

Readiness, drive cycles, software updates, dealer reflashes, blah, blah, blah

ANYONE DYNO YET?
__________________
Toy: 2008 Silver Z4MC 300WHP/241TQ

Mods: OEM Euro Headers, RPI Scoop

Daily: 2010 Tacoma Double Cab
Appreciate 0
      08-17-2012, 07:14 PM   #285
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

thanks for the input fellas. i also contacted evolve and they said to google obdII bmw drive cycle sequence and see what i come up with.

i've had the tune for probably 2k miles and even a track day...guess it's that tricky.
__________________
'07 MCoupe
lots of mods
Appreciate 0
      08-21-2012, 07:43 PM   #286
inTgr8r
Major General
inTgr8r's Avatar
Canada
121
Rep
8,227
Posts

Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

iTrader: (7)

how has the success rate been for "catless 02 ready tune" ???

I see that zubydafa has had some issues but has it worked for everyone else?
__________________
Alpinweiss '07 M Coupe •DKF Section1•RPi GT exhaust•Fabspeed Headers•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•H&R COs + ARBs•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:44 PM.




zpost
zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST