ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      03-18-2012, 12:41 PM   #1
ski_rush
Private
 
ski_rush's Avatar
 
Drives: 2007 Z4 3.0i
Join Date: Mar 2011
Location: Pennsylvania

Posts: 56
iTrader: (0)

Garage List
2007 Z4  [0.00]
Took car out of storage today...noticed a tick in the motor

Hi everyone, please help...I took the Z out of storage today. The car started up fine with no issues. However, I noticed a pretty distinct ticking noise coming from the engine. I have never noticed this before, ever, with my car. I started the car a month ago and didn't notice it then either.

I realize that this is extremely difficult to diagnose over the forum, but please help me determine how to figure out what is causing this noise and how I can fix it.

I checked the oil level and it said "OK".


Thanks,
sr
__________________
ski_rush is offline   United_States
0
Reply With Quote
      03-18-2012, 12:58 PM   #2
gtMc
Captain
 
gtMc's Avatar
 
Drives: '08 MC
Join Date: Nov 2011
Location: NNJ

Posts: 703
iTrader: (1)

Garage List
'03 e39 m sport  [0.00]
'08 mc  [0.00]
How long did you let it run for
__________________
ZHP/Zeck CDV/VT engine mounts/RE trans mounts;clutch stop/Stubby
gtMc is offline  
0
Reply With Quote
      03-18-2012, 01:26 PM   #3
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,538
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Sounds like a collapsed HLA, just from being sat so long. A good drive and some revs after it's warm should help.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      03-18-2012, 01:35 PM   #4
Aries326
Major
 
Aries326's Avatar
 
Drives: 2008 Z4 3.0si
Join Date: Aug 2011
Location: NY

Posts: 1,002
iTrader: (2)

Garage List
Sounds like the infamous N52 lifter tick. I've got it in my Z. It's covered if you're still under warranty. There's a huge thread on it in the 3 Series section.
__________________
Aries326 is offline   United_States
0
Reply With Quote
      03-18-2012, 02:52 PM   #5
ski_rush
Private
 
ski_rush's Avatar
 
Drives: 2007 Z4 3.0i
Join Date: Mar 2011
Location: Pennsylvania

Posts: 56
iTrader: (0)

Garage List
2007 Z4  [0.00]
Quote:
Originally Posted by gtMc View Post
How long did you let it run for
I only let it run for about 5 minutes because I was pretty worried. I didn't rev it. It was just at idle.

sr
__________________
ski_rush is offline   United_States
0
Reply With Quote
      03-18-2012, 09:27 PM   #6
santov
Lieutenant
 
santov's Avatar
 
Drives: 2007 Z4 3.0si White over Beige
Join Date: Dec 2010
Location: Bay Area, Calif

Posts: 483
iTrader: (8)

The dealer will try new lifters, but you can insist in new heads. The tick was super annoying and the first fix BMW offered was to trev the engine at 5k for 3min. They finally came up with a fix kit when dealers started charging $9k fix jobs under warranty.
santov is offline  
0
Reply With Quote
      03-18-2012, 10:10 PM   #7
ski_rush
Private
 
ski_rush's Avatar
 
Drives: 2007 Z4 3.0i
Join Date: Mar 2011
Location: Pennsylvania

Posts: 56
iTrader: (0)

Garage List
2007 Z4  [0.00]
I will take the car in to a BMW dealership. I think I'm still under my CPO warranty. However, I'm guessing the SA is more interested in saving the company money so will be more inclined to say its nothing.

Is there something I should say in particular to encourage them to take it serious? Is there something that I can refer them to?
__________________
ski_rush is offline   United_States
0
Reply With Quote
      03-18-2012, 10:48 PM   #8
santov
Lieutenant
 
santov's Avatar
 
Drives: 2007 Z4 3.0si White over Beige
Join Date: Dec 2010
Location: Bay Area, Calif

Posts: 483
iTrader: (8)

There's lots of you tube videos of the noise. Any BMW dealer will know N52 "lifter tick".
santov is offline  
0
Reply With Quote
      03-21-2012, 08:40 PM   #9
Shota15
Private
 
Shota15's Avatar
 
Drives: 07 Z4 M Coupe
Join Date: Sep 2011
Location: Masschusetts

Posts: 50
iTrader: (0)

Garage List
Try adding a pint of Marvel Mystery Oil to the oil, I have added a pint to all the cars I have ever owned when I change the oil (something my Father had always done). I am a firm believer in frequent oil changes rather than the 12-15K recommended intervals by BMW and other manufactures.
Shota15 is offline   United_States
0
Reply With Quote
      03-21-2012, 09:52 PM   #10
MHeavNC
Turd in the Punch Bowl
 
MHeavNC's Avatar
 
Drives: 2007 Z4 3.0i /// 2008 M Coupe
Join Date: Aug 2010
Location: North Carolina

Posts: 229
iTrader: (0)

Marvel Mystery Oil?? Is that a Stan Lee product? I agree 100% with the more frequent oil changes...
MHeavNC is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:37 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST