ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-08-2012, 02:43 PM   #1
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

DKF S pipe/300 cell cats review

So I had the Euro headers installed and attempted to relocate my O2s and EGT and was having problems with the set up so I looked for an alternative solution. I turned to DKF for this solution. I purchased the S pipe with 300 cell cats to mate up to the OEM X pipe with El Diablo mufflers. I did not want to change the X pipe because I did not want any more rasp and did not want it too much louder.

I do not have pictures at this time but you all have seen the pictures posted already.

The quality was top notch. Fitment was excellent.

The car definitely seems to pull harder too.

I definitely recommend DKF. The service was excellent and the parts were better than expected

I raced my car out at a local event last week and will try to get some videos up. I will be heading to VIR in August and will get some great coverage then as well.


PS I do have a set of DKF hangers that I think I am not going to put on. The quality is amazing but I think I am going to stick with the stock hangers since I like my fitment. If anyone wants mine they are brand new shoot me a pm and I will hook up the price.

Edit Here are some videos... sorry I couldn't figure out how to embed it so if someone could help with this. This is at Wacky Wednesdays at Langley speedway in Hampton, VA. Just some cheap local ways to get on a track.







Last edited by avsbmw; 05-28-2012 at 02:10 PM. Reason: Photo Added
Appreciate 0
      05-08-2012, 03:54 PM   #2
DanFromTucson
Private First Class
United_States
1
Rep
140
Posts

 
Drives: Z4 M Coupe
Join Date: Aug 2011
Location: Austin, TX

iTrader: (0)

I think the big question most of us are wondering... do you have a CEL after installing the cats?
Appreciate 0
      05-08-2012, 04:12 PM   #3
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

Knock on wood but no CEL for over 200 miles!
Appreciate 0
      05-08-2012, 05:08 PM   #4
DanFromTucson
Private First Class
United_States
1
Rep
140
Posts

 
Drives: Z4 M Coupe
Join Date: Aug 2011
Location: Austin, TX

iTrader: (0)

I should have asked, but I'm assuming you don't have a tune (at least not one that disables the CEL).

Did you just lengthen your post-cat O2 sensor wires to plug in behind the new cats?
Appreciate 0
      05-08-2012, 09:27 PM   #5
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

yes no tune. just euro headers. DKF S pipe 300 cell cats. OEM x pipe. El diablo mufflers
Appreciate 0
      05-08-2012, 09:27 PM   #6
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

Quote:
Originally Posted by DanFromTucson View Post
I should have asked, but I'm assuming you don't have a tune (at least not one that disables the CEL).

Did you just lengthen your post-cat O2 sensor wires to plug in behind the new cats?
I did not lengthen the post cat o2 sensor wires. Just rerouted them
Appreciate 0
      05-09-2012, 08:59 PM   #7
Jumbosock
Captain
Jumbosock's Avatar
10
Rep
809
Posts

 
Drives: 2007 M coupe
Join Date: Apr 2011
Location: San Diego

iTrader: (0)

Give us an update after about a thousand miles or so.
Appreciate 0
      05-09-2012, 10:13 PM   #8
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

will do. just got some hoosier R6 so it will be back at the track shortly

I am currently at about 250 miles btw
Appreciate 0
      05-09-2012, 10:47 PM   #9
zubydafa
tosser
Isle of Man
9
Rep
988
Posts

 
Drives: '07 Z4MC
Join Date: Jul 2011
Location: Allentown, PA

iTrader: (0)

fabspeed headers here.

i have a cel
__________________
'07 MCoupe
lots of mods
Appreciate 0
      05-10-2012, 12:39 AM   #10
johanness
Banned
23
Rep
1,741
Posts

 
Drives: 2008 Z4MC
Join Date: Aug 2010
Location: Seattle, Vancouver

iTrader: (3)

Garage List
Quote:
Originally Posted by zubydafa View Post
fabspeed headers here.

i have a cel
Did you ever get the codes your throwing? Once you have those, it's fairly straight-forward to diagnose.
Appreciate 0
      05-15-2012, 12:55 AM   #11
Beedub
Brigadier General
United Kingdom
54
Rep
4,085
Posts

 
Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

very interesting to see these finally make it onto the running n/A car..... hows things going with this??
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      05-15-2012, 07:57 AM   #12
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

car is running great. now about 450 miles with no problems. going to the track tomorrow as long as its not raining and will try to get video.
Appreciate 0
      05-15-2012, 09:29 AM   #13
ZStig
Major General
101
Rep
7,241
Posts

 
Drives: VT2-525 M Roadster
Join Date: Jun 2008
Location: Delray Beach, FL

iTrader: (3)

dyno of before/after these parts?
__________________
Appreciate 0
      05-15-2012, 10:11 AM   #14
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

sorry never had a chance to dyno. The car was not running right before the DKF S pipe due to a bad relocation of the O2s or EGT so it would not have been a proper dyno anyways.
Appreciate 0
      05-25-2012, 03:31 AM   #15
pal
First Lieutenant
pal's Avatar
8
Rep
351
Posts

 
Drives: Z4 M Coupe
Join Date: Nov 2007
Location: New Jersey

iTrader: (1)

Do you have pics of the original relocation when you had codes?

I have been running with relocated O2s and EGT and Euro M3 headers for about 2.5 yrs and no codes or drivability issues.

Others have had issues related to how the reloc bungs were installed - position or to long a bung that puts O2s far away to get a good reading.

Even with the post cat O2s out of the car, I just had codes but drivability was fine.

My details are here-

http://www.zpost.com/forums/showthread.php?t=331906&highlight=Header+install
Appreciate 0
      05-27-2012, 01:59 PM   #16
Beedub
Brigadier General
United Kingdom
54
Rep
4,085
Posts

 
Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

updates on issues with these cats??? looks like DKF got the sensor placement right!!
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      05-27-2012, 08:44 PM   #17
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

Quote:
Originally Posted by Beedub
updates on issues with these cats??? looks like DKF got the sensor placement right!!
I have about 700 miles on these cats and the car is running great with no CEL
Appreciate 0
      05-28-2012, 02:11 PM   #18
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

Photo and videos added. Sorry I did not know how to embed.
Appreciate 0
      12-09-2012, 12:56 PM   #19
IDLE TIME
Private
IDLE TIME's Avatar
United_States
0
Rep
85
Posts

 
Drives: still searching
Join Date: Oct 2012
Location: peoria il

iTrader: (0)

Bump any more info
Appreciate 0
      12-10-2012, 08:53 AM   #20
avsbmw
Captain
8
Rep
831
Posts

 
Drives: 07 Z4MC
Join Date: Jul 2009
Location: Hampton Roads VA

iTrader: (1)

Quote:
Originally Posted by IDLE TIME View Post
Bump any more info
I have driven a couple thousand miles and have the evolve tune. The car has been running great and pulling really hard with no codes.
Appreciate 0
      12-10-2012, 07:21 PM   #21
IDLE TIME
Private
IDLE TIME's Avatar
United_States
0
Rep
85
Posts

 
Drives: still searching
Join Date: Oct 2012
Location: peoria il

iTrader: (0)

Quote:
Originally Posted by avsbmw
Quote:
Originally Posted by IDLE TIME View Post
Bump any more info
I have driven a couple thousand miles and have the evolve tune. The car has been running great and pulling really hard with no codes.
Really glad to hear that many people have had questions. Keep us posted. Glad you like the setup
Appreciate 0
      03-19-2013, 06:43 PM   #22
inTgr8r
Major General
inTgr8r's Avatar
Canada
113
Rep
8,081
Posts

 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

iTrader: (7)

Quote:
Originally Posted by avsbmw View Post


Just wanted to share my set up with you guys. I got one of the original test pipes from DKF and have been extremely happy. I have euro headers OEM xpipe (wanted to keep the raspy down) and el diablo mufflers. I also have the evolve tune. The S pipe is really good quality. The car has been running great with no CEL for several thousand miles.
Love the design of this DKF section 1 exhaust replacement kit.
I can't wait until the GB gets rolling on these.
.....off to bug Doug
__________________
Alpinweiss '07 M Coupe •DKF Section1•RPi GT exhaust•Fabspeed Headers•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•H&R COs + ARBs•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:46 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST