ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      08-04-2014, 07:21 AM   #1
SwissArmy
Why so serious?
SwissArmy's Avatar
Canada
32
Rep
541
Posts

Drives: 2004 BMW z4 3.0i SMG
Join Date: Dec 2012
Location: Toronto

iTrader: (0)

Limp Mode w/ Codes [1st gear = Reverse?!]

Hey guys.

2004 BMW Z4 3.0i w/ SMG Transmission. Currently in limp mode and have the following codes. All hard coded, nothing can be cleared.

Back story: I got the SMG Pump replaced TWICE. The first time around the pump worked, no codes. But then the pump failed. Second time around, with a brand new pump again. No codes, drove for a day. The next day, INTERMITTENT limp mode. The next day, stuck in limp mode.

OFTEN, 1st gear would throw me into Reverse - SCARY when taking off on a green light

Maybe it was not flashed/re-taught properly? Alternator? Regulator? TCM? Battery?

I've had the battery tested, and replaced twice with new batteries.

IF it is the alternator/regulator, please visit my other thread: http://www.zpost.com/forums/showthread.php?p=16404539

Engine Codes

299A Error Management EGS
281D BSD Alternator Signal Implausible
281C BitData Port Signal Implausible
27C3 Thermal Oil Level Sensor

Tranny Codes
20916 (51B4)
20213 (4EF5)

I get other sensor codes like, Convertible roof top, Dashboard cluster, Heating/AC etc. But they have been cleared.

Your thoughts? Thanks

Last edited by SwissArmy; 08-04-2014 at 07:28 AM.
Appreciate 0
      10-11-2014, 12:28 AM   #2
rudyboy
Enlisted Member
2
Rep
46
Posts

Drives: Bmw e85,
Join Date: Jul 2005
Location: los angeles

iTrader: (0)

Same situation with mine. Auto with smg.. 138,000 miles...tranny needs rebuilt...
Appreciate 0
      10-11-2014, 12:07 PM   #3
pokeybritches
Colonel
pokeybritches's Avatar
Bahrain
121
Rep
2,584
Posts

Drives: ESS/G-Power Z4M, VF Z4, 987.2
Join Date: Sep 2009
Location: Amwaj

iTrader: (12)

Garage List
2006 BMW Z4M  [5.00]
2006 BMW Z4M  [4.25]
2003 BMW Z4 3.0i  [4.50]
A bad alternator can cause all kinds of coding errors. My M thought it was an automatic, and wouldn't start because the gear selector wasn't in park
__________________


VF Engineering Z4 3.0i, ESS Z4M, G-Power Z4M, 987.2 Cayman S
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:36 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST