ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > Z4 DIY (Do It Yourself) Articles
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      08-21-2016, 12:32 PM   #67
pcube
Private First Class
pcube's Avatar
21
Rep
104
Posts

Drives: Z4MC
Join Date: Feb 2016
Location: Singapore

iTrader: (0)

Quote:
Originally Posted by Mirko View Post
The turn signal's were only on in one of the pictures cause I turned the light switch to the first position. Otherwise my car is coded to show only the angle eyes as the day time running lights. In North America we are mandated to have the turn signals on when the lights are on. In Europe and I suspect Singapore you don't have to have them on. Did your turn signal lights turn on after installing the LED bulb or were they an option you could turn on before?
You are right that there aren't such regulations in Singapore, so my turn signals were never on regardless of which position the light switch was in. My AEs are not programmed as DRLs either, and will only activate when the head lights are on. The turn signal only came on after installing the LED bulb. The other side with the stock bulb remained normal.

Tomorrow I'm gonna turn on my lights with just the back cover removed, and see if the turn signal is on. Will report back.
Appreciate 0
      08-21-2016, 12:35 PM   #68
pcube
Private First Class
pcube's Avatar
21
Rep
104
Posts

Drives: Z4MC
Join Date: Feb 2016
Location: Singapore

iTrader: (0)

Quote:
Originally Posted by XMetal View Post
Your North America statement is 1/2 correct - United States do NOT require DRL

My guess as why the parking lights were on after installing LED has to do with coding. BMW's code may turn on the parking light of that side if it detects a bulb out on the angel eye of that side as a safety feature. You want something to light up on both sides of a car so it doesn't confuse people - that it's a car and not a motorcycle. Try coding out monitoring on the angel eye to see if this is still an issue?
That would be the most ideal solution, but unfortunately I do not have any coding equipment readily available.

On a side note, what's the recommended choice for this? bcables or carly?
Appreciate 0
      08-21-2016, 05:44 PM   #69
Caddyshk
M = Midlife Crisis
Caddyshk's Avatar
Canada
49
Rep
2,006
Posts

Drives: 2006 Z4MC Interlagos
Join Date: May 2007
Location: Fort Erie, Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by Mirko View Post
The turn signal's were only on in one of the pictures cause I turned the light switch to the first position. Otherwise my car is coded to show only the angle eyes as the day time running lights. In North America we are mandated to have the turn signals on when the lights are on. In Europe and I suspect Singapore you don't have to have them on. Did your turn signal lights turn on after installing the LED bulb or were they an option you could turn on before?
Mirko; US cars only have the Halo DRL's on when lights to off. Canadian coded cars were shipped with two lines of code turned on that essentially has all our running lights on at all times regardless of position including off; including rear plate. Ian and I found those two lines of code and turned them off on my car this past April. Just Halo DRL's in off position now.
__________________
2006 Z4MC - #LL93158
SS Race Cans, RE X Pipe, DKF Sec 1, Fabspeed Headers, OE STB, AS Shifter, Dave Z CDV, GC Coil Overs, Stoptech lines, Hawk DTC Pads, RE Clutch Stop, RE Transmission Mounts, Vibra-Technics Engine Mounts, Poly FCAB & RTAB, LeatherZ M Shift Boot, Tekarbon Rear Spoiler, CF Grills, Advan RS DGM
Appreciate 0
      08-21-2016, 08:37 PM   #70
Mirko
Captain
Mirko's Avatar
Canada
144
Rep
986
Posts

Drives: E86 Z4M, E90 328i, E84 X1
Join Date: Apr 2011
Location: Toronto

iTrader: (2)

Quote:
Originally Posted by pcube View Post
That would be the most ideal solution, but unfortunately I do not have any coding equipment readily available.

On a side note, what's the recommended choice for this? bcables or carly?
I recommend Carly. That is what I used to turn off the monitoring of the angle eyes and a few other things. You just have to use the cable for it on work our cars. I've also used it to code our 328 and X1.
__________________
08 M Coupe Ceramic Black Fabspeed Headers MCS 1WNR Poly FCAB Stoptech BBK Vibra-Tech Epic Tune Apex EC7 RPI Scoop Eventuri Stromung Rogue X Pipe Varis Diffuser CF E92 GTS Wing CF Roof
Appreciate 0
      08-21-2016, 11:16 PM   #71
pcube
Private First Class
pcube's Avatar
21
Rep
104
Posts

Drives: Z4MC
Join Date: Feb 2016
Location: Singapore

iTrader: (0)

Just reinstalled the LEDs and the turn signals are back on again. The back cover has nothing to do with it.

Looks like I'll need to make a trip down to my indy to get this sorted. Meanwhile having the turn signals permanently on isn't all that bad...

*Update*

Dropped by my indy, and he wasn't able to code the error message away! He remembers having done this for a Z4 previously, but apparently there was a software update and that function is no longer available. Ugh so much headache for such a simple mod.

Will the carly cable be a guaranteed solution? It's a lot of money to spend on a failed experiment...

Last edited by pcube; 08-22-2016 at 05:16 AM.
Appreciate 0
      08-22-2016, 11:33 AM   #72
Asianoak
Second Lieutenant
Asianoak's Avatar
United_States
28
Rep
263
Posts

Drives: '07 BMW Z4 Coupe & X3
Join Date: Jun 2013
Location: Southern Oregon

iTrader: (2)

I just used Carly this weekend to eliminate my bulb out error from the LED angel eye bulb and parking lights. It's a really convenient app to use and I highly recommend it. While it's not as in depth as a laptop may be the convenience and ease of use is great and if you buy adaptors for different models you'll get a lot of use out of it. I've used the app on my old E92, my current X3 and Z4, some friends cars and multiple vehicles I was looking to buy to check for hidden service codes.
Appreciate 0
      08-22-2016, 12:32 PM   #73
AmmarYasirA
Ammar
AmmarYasirA's Avatar
United_States
46
Rep
384
Posts

Drives: a lot
Join Date: Sep 2013
Location: Atlanta

iTrader: (0)

@Asianoak I edited that post very recently so that's probably why you didn't see it before.

As for the bulb staying on. (This was mentioned on my thread as well) I can't say at all what the issue would be. Coding is the way to go though I would say.
__________________
W211 E320 BlueTec ~Flint/Ash - DD~
E85 ///M Roadster ~SapphireBlack/Imola - Toy~
W219 CLS 63 ////AMG ~JetBlack/Black - Garage Queen (Its for sale too! ~
Appreciate 0
      08-23-2016, 10:19 AM   #74
Mirko
Captain
Mirko's Avatar
Canada
144
Rep
986
Posts

Drives: E86 Z4M, E90 328i, E84 X1
Join Date: Apr 2011
Location: Toronto

iTrader: (2)

Quote:
Originally Posted by pcube View Post
Just reinstalled the LEDs and the turn signals are back on again. The back cover has nothing to do with it.

Looks like I'll need to make a trip down to my indy to get this sorted. Meanwhile having the turn signals permanently on isn't all that bad...

*Update*

Dropped by my indy, and he wasn't able to code the error message away! He remembers having done this for a Z4 previously, but apparently there was a software update and that function is no longer available. Ugh so much headache for such a simple mod.

Will the carly cable be a guaranteed solution? It's a lot of money to spend on a failed experiment...
Can't say as I haven't run into your specific problem.

I bought this cable and have had success using it on my M and another members car. I've also used it on my E90 and E84.

http://www.ebay.ca/itm/271621954745?...%3AMEBIDX%3AIT

You will have to solder two pins together to make it work on our cars. I believe it was 7 & 9 but please confirm before you do that.
__________________
08 M Coupe Ceramic Black Fabspeed Headers MCS 1WNR Poly FCAB Stoptech BBK Vibra-Tech Epic Tune Apex EC7 RPI Scoop Eventuri Stromung Rogue X Pipe Varis Diffuser CF E92 GTS Wing CF Roof
Appreciate 1
pcube20.50

      09-02-2016, 10:10 AM   #75
pcube
Private First Class
pcube's Avatar
21
Rep
104
Posts

Drives: Z4MC
Join Date: Feb 2016
Location: Singapore

iTrader: (0)

I managed to code the dash warning lights out using NCS expert, basically disabled cold and hot monitoring of the high beam. This also made the turn signals in the headlights behave normally again (ie not constantly on).

Also turned on the AEs as DRL at the same time

Thanks for all the advice!
Appreciate 2
Mirko143.50
wdb811.00

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:58 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST