ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Technical Talk > Engine, Exhaust, Drivetrain Modifications
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      05-24-2010, 11:41 AM   #1
zKnuds3712
Private
 
zKnuds3712's Avatar
 
Drives: 2003 Z4
Join Date: May 2010
Location: North Jersey

Posts: 76
iTrader: (0)

HELP!! squeaky belt/pullies

Yesterday morning as i started driving my car started squeaking from the belt. So immediately i went out and bought belt dressing which i thought would solve the problem......it didnt. I found this video on youtube which is identical to my noise





I figure before i take any of the youtube users comments seriously i would ask here since everyone here is so knowledgeable .

Im thinking its probably the alternator, but my brother seems to think it is more likely a pully bearing. Its only coming from the 4 or 5 wheels on the same side as the alternator I know that for sure.
zKnuds3712 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Tags
alternator, belt, pullies, squeak

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:40 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST