ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      03-02-2013, 07:09 PM   #1
alfredoporro
Enlisted Member
0
Rep
49
Posts

 
Drives: 03 Z4 3.0 6 speed manual-Sold
Join Date: Jan 2013
Location: Marin County, CA SF bay area

iTrader: (0)

New E85 Z4 owner

Hello Everyone!

I introduced myself sometime ago in the check in and say hello section.

This is my car:



My car is a 2003 Z4 3.0 6 speed manual with 77xxx miles and has the following options:



I'm not new to BMW, I've had the following cars:
  1. White 2002 BMW 325i automatic
  2. Red 1997 BMW Z3 1.9 5 speed manual
  3. Orient Blue Metallic 2001 BMW 330ci 5 speed manual sport and premiun packages with rear parking sensors (I miss that)
  4. Black 2000 BMW 323ci automatic sport and premiun packages

Like you can see, I like the 3 series and the Z series. My another option besides my Z4 was an E46 M3, but gas prices are to high and I missed the feeling of driving a roadster.

I'm very happy with my Z4. I'm glad to have the 3.0 engine again and together with the 6 speed manual. It is really fun to drive.

The design of the car is awesome. I have received a lot of compliments so far and even more than in the past with my other cars.

The interior of the car is really nice, definitely an upgrade from the Z3 interior. However, I think the materials in the E46s are bit better. Also, I miss the sport seats since I have the regular seats in the Z4.

One of the things I have learn some far is that I have to be careful in the driveways. Does everyone have this problem? I think our cars are very lowww

So far the cooling system has been overhauled, head gasket has been replaced, all spark plugs have been replaced, front control arm bushings have been replaced, and fresh oil change. I also installed the AUX cable. I bought the mini cooper version and it works great. Sometimes I get some interference, Does any of you know why?

The car is in great shape, but it is not perfect. My remote key was not working properly. Symptoms are that sometimes lock/unlock doors and trunk but most of the time it doesn't work. After reading some threads, I contacted Scott from bmwgm5.com and after telling the problems I was having, it looks like my remote key it's the problem not the GM5. I just sent my key yesterday to him, now just wait.

Another issue I have is that the fill-in flap does not lock when I lock the doors. After checking I found that the Filler flap actuator is pushed inside and it is not in the location it is supposed to be. Look at the picture:



You can see the hole and inside you can see part of the Filler flap actuator. Have any of you had this problem? Any help would be appreciate it.



#22 in the diagram is the actuator that is either pushed back or missing.

Also, I want to replace the trasmission oil. What do you recommend? OEM transmission oil, red line, liqui-moly? What have you used that is good? I want to make the shifting smoother since it is kind of notchy now, specially from 1st to 2nd to 3rd.

I'm looking forward to learn more about my Z4. So far I like this forum because the people her are very helpful and nice, and a lot of good information.

Thank you! and your help will be appreciated

Last edited by alfredoporro; 03-28-2013 at 06:51 PM.
Appreciate 0
      03-03-2013, 07:31 AM   #2
brock5ga
Enlisted Member
0
Rep
46
Posts

 
Drives: 03 Z4 3.0i
Join Date: Mar 2013
Location: Monroe, GA

iTrader: (0)

I have had my 03 3.0 for about a year and just making it over here as well. Nose is long and low, you have to be careful everywhere. When they paved the main road here by my house, they did not blend it with the side road. I have to crawl and hit it at an angle to keep from scrubbing. Something which the people behind me on the main road love when I am turning in. I, too, had the notchy shifting feeling. Replaced trans fluid with the Pentosin MTF2 , which is the factory fluid. O'Reilly was able to order and have the same day. This helped a good deal as mine had 89K when I purchased it, but didn't solve it completely. I then ordered a ZHP weighted shift knob and that helped smooth it out to a barely noticeable level. Can't help on the fuel door issue. I only get static on the aux input if I have my phone charger connected while using it. If I leave the charger disconnected, it plays without any background noise.
Appreciate 0
      03-05-2013, 07:07 PM   #3
alfredoporro
Enlisted Member
0
Rep
49
Posts

 
Drives: 03 Z4 3.0 6 speed manual-Sold
Join Date: Jan 2013
Location: Marin County, CA SF bay area

iTrader: (0)

Quote:
Originally Posted by brock5ga View Post
I have had my 03 3.0 for about a year and just making it over here as well. Nose is long and low, you have to be careful everywhere. When they paved the main road here by my house, they did not blend it with the side road. I have to crawl and hit it at an angle to keep from scrubbing. Something which the people behind me on the main road love when I am turning in. I, too, had the notchy shifting feeling. Replaced trans fluid with the Pentosin MTF2 , which is the factory fluid. O'Reilly was able to order and have the same day. This helped a good deal as mine had 89K when I purchased it, but didn't solve it completely. I then ordered a ZHP weighted shift knob and that helped smooth it out to a barely noticeable level. Can't help on the fuel door issue. I only get static on the aux input if I have my phone charger connected while using it. If I leave the charger disconnected, it plays without any background noise.
Thank you for tips!

I had the ZHP knob in my 330ci and I liked it a lot. I'll check the Pentosin MTF2
Appreciate 0
      03-06-2013, 08:41 PM   #4
sinbad4
Private
0
Rep
57
Posts

 
Drives: 08 Z4MR
Join Date: Mar 2013
Location: MN

iTrader: (0)

Hi, alfredoporro,

Very pretty car!

I am new too.. just picked mine up about 5 weeks ago. It's grey as well. Waiting for snow to melt; it's taking FOREVER. Until then; busied myself by removing logos and ordering stuff.. like tire stem caps, and side skirts.

I have been hitting the forums hard. I have seen at least a couple posts were the gas cap actuator has fallen behind the panel. My own had retracted too far to be usable (dealer fixed under warranty). Sorry I don't have direct link for you; but know there's help out there for this issue.
Appreciate 0
      03-06-2013, 11:19 PM   #5
3point0
Lieutenant
3point0's Avatar
Canada
5
Rep
410
Posts

 
Drives: 2005 z4 3.0
Join Date: Jun 2012
Location: Vancouver

iTrader: (2)

Garage List
2006 Audi S4 Avant  [0.00]
2005 BMW Z4  [2.75]
welcome both of you! Sinbad4 please post pics (maybe in a different thread - don't want to hijack) You'll find plenty of really useful info on this forum, being a relative noob myself, i found this forum particularly active and full of advice-ready users.
__________________

2005 Z4 3.0 steptronic | TiSilver on Black | sport & premium package | 108s | Msport seats | wind deflector
OMP strut bar | blacked out emblems | de-french-fried | sound gen | DIY aux input | custom speedo logos | stubby antenna | polished exhaust tips
Appreciate 0
      03-11-2013, 03:33 PM   #6
thelinux
Private First Class
United_States
1
Rep
154
Posts

 
Drives: 2008 Z4 3si
Join Date: Feb 2013
Location: Irvine, CA

iTrader: (0)

Where did you get that option list for your car?
Appreciate 0
      03-12-2013, 10:06 AM   #7
Jstic
Private First Class
1
Rep
118
Posts

 
Drives: 06 Z4 3.0i
Join Date: Aug 2012
Location: CT

iTrader: (0)

Quote:
Originally Posted by thelinux View Post
Where did you get that option list for your car?

You can get that information here: http://www.rubmw.ru/vincode/eng/
Appreciate 0
      03-29-2013, 07:14 PM   #8
alfredoporro
Enlisted Member
0
Rep
49
Posts

 
Drives: 03 Z4 3.0 6 speed manual-Sold
Join Date: Jan 2013
Location: Marin County, CA SF bay area

iTrader: (0)

Quote:
Originally Posted by brock5ga View Post
I have had my 03 3.0 for about a year and just making it over here as well. Nose is long and low, you have to be careful everywhere. When they paved the main road here by my house, they did not blend it with the side road. I have to crawl and hit it at an angle to keep from scrubbing. Something which the people behind me on the main road love when I am turning in. I, too, had the notchy shifting feeling. Replaced trans fluid with the Pentosin MTF2 , which is the factory fluid. O'Reilly was able to order and have the same day. This helped a good deal as mine had 89K when I purchased it, but didn't solve it completely. I then ordered a ZHP weighted shift knob and that helped smooth it out to a barely noticeable level. Can't help on the fuel door issue. I only get static on the aux input if I have my phone charger connected while using it. If I leave the charger disconnected, it plays without any background noise.
Thanks for the help! I installed the ZHP knob and planning to do the oil change next week!
Appreciate 0
      03-29-2013, 07:16 PM   #9
alfredoporro
Enlisted Member
0
Rep
49
Posts

 
Drives: 03 Z4 3.0 6 speed manual-Sold
Join Date: Jan 2013
Location: Marin County, CA SF bay area

iTrader: (0)

Quote:
Originally Posted by sinbad4 View Post
Hi, alfredoporro,

Very pretty car!

I am new too.. just picked mine up about 5 weeks ago. It's grey as well. Waiting for snow to melt; it's taking FOREVER. Until then; busied myself by removing logos and ordering stuff.. like tire stem caps, and side skirts.

I have been hitting the forums hard. I have seen at least a couple posts were the gas cap actuator has fallen behind the panel. My own had retracted too far to be usable (dealer fixed under warranty). Sorry I don't have direct link for you; but know there's help out there for this issue.
As soon as I have more time I'll take a look at that. I feel the actuator still working because I feel it engages when I lock the doors. I hope I can put it back to its place
Appreciate 0
      03-29-2013, 07:17 PM   #10
alfredoporro
Enlisted Member
0
Rep
49
Posts

 
Drives: 03 Z4 3.0 6 speed manual-Sold
Join Date: Jan 2013
Location: Marin County, CA SF bay area

iTrader: (0)

Quote:
Originally Posted by 3point0 View Post
welcome both of you! Sinbad4 please post pics (maybe in a different thread - don't want to hijack) You'll find plenty of really useful info on this forum, being a relative noob myself, i found this forum particularly active and full of advice-ready users.
Thank you!!

I find people here more friendly and helpful
Appreciate 0
      03-29-2013, 07:19 PM   #11
StickMon
My other car is on Mars
StickMon's Avatar
United_States
19
Rep
1,460
Posts

 
Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (0)

I had the same thing going on with the gas flap lock when I bought my car.
Fixed it with a plastic hole plug, so that (much) water can't get in.
The center console lock also was disconnected. Decided to leave bad enough alone.
Obviously they both went wrong on the previous owner.

While researching the gas flap lock, I found a thread where somebody was looking to replace their pin because a gas thief broke it. The obvious conclusion is it does nothing to deter theft.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:11 AM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST