ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      11-11-2012, 02:15 PM   #1
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

Windshield Washers Problem

Hey guys, just noticed that my nozzles on the hood stopped working. Headlight cleaning ones still spray its just the ones on the hood that aren't operating. Anybody have any experience with this?
Appreciate 0
      11-11-2012, 03:41 PM   #2
Finnegan
Major General
Finnegan's Avatar
United_States
80
Rep
6,507
Posts

 
Drives: Sapphire Black/Black Z4Mc
Join Date: Oct 2008
Location: At the track..or wishing I were at the track

iTrader: (18)

Have you traced the lines back to the washer pump? All of them are attached to the same pump, so sounds like a kink or obstruction in the line to me.
Appreciate 0
      11-11-2012, 03:43 PM   #3
inTgr8r
Major General
inTgr8r's Avatar
Canada
113
Rep
8,099
Posts

 
Drives: 07 M Coupe
Join Date: Mar 2006
Location: Toronto

iTrader: (7)

^whs
.....or plugged nozzles.
__________________
Alpinweiss '07 M Coupe •DKF Section1•RPi GT exhaust•Fabspeed Headers•Autosolutions SSK•APR splitter•Tekarbon headlights•StrongStrut STB•H&R COs + ARBs•Poly FCAB/RTAB•Volk Racing G2•Direzza ZII•Stoptech BBK•Vibra-Tech mtr mounts•
Appreciate 0
      11-11-2012, 11:55 PM   #4
Loogey Clapp
First Lieutenant
Loogey Clapp's Avatar
3
Rep
375
Posts

 
Drives: 2006 Z4 3.0si
Join Date: Jul 2011
Location: Everett, WA, USA

iTrader: (0)

Quote:
Originally Posted by inTgr8r View Post
^whs
.....or plugged nozzles.
I was thinking perhaps dried wax in the nozzles.
__________________
Appreciate 0
      11-12-2012, 12:30 AM   #5
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

so today i took checked the nozzles and lines everything look clogg free and clear, i then decided to check the pumps. it looks like windshield nozzle pump went out, it showed rust on the outside of the unit. Since i had the tank out, i went ahead and checked to see if the grommets were clogged on both pumps, NOPE. Well now I happened to make the headlight washer not work as well -_-*. The pump is fine, i still hear it buzz, but no fluid is being channeled to them, i may have missed something. Got too cold and dark so i will attempt to fix this another day. Any ideas where I can get another pump cheap?
Appreciate 0
      11-14-2012, 06:06 PM   #6
hays0023
Private
United_States
0
Rep
60
Posts

 
Drives: 2007 Z4MR
Join Date: Oct 2008
Location: Tucson

iTrader: (1)

Interesting! This exact same thing happened to me....I ordered a new pump and was going to change it out.

Here is hoping it works.
Appreciate 0
      11-16-2012, 11:54 AM   #7
davesz4mc
Second Lieutenant
4
Rep
274
Posts

 
Drives: 2007 z4mc
Join Date: Feb 2012
Location: San Antonio, Tx

iTrader: (0)

The headlight washers and winshield washers are two sperate pumps and line systems. My windshield washer pump (closest to firewall) recently went out as well, while it was at the body shop. I got a replament from a local auto parts shop that was cheap and I am running that!
__________________
2007 Z4MC, 1" drop H&R Springs, Evolve Tunning, Headers, K&N Filter, RPI scoop, Red top high energy coils, UUC Red Poly mounts (none bolt-through), UUC Lightweight Flywheel with Organic Clutch and a custom exhaust with just one AeroTurbine muffler.
Appreciate 0
      11-20-2012, 05:54 PM   #8
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

The culprit!!



Ebay + $10 later, car is spraying fluid like a super soaker once again!
Appreciate 0
      06-20-2013, 08:51 PM   #9
Master Apex
Private
United_States
0
Rep
95
Posts

 
Drives: '07 Z4M & '06 E60M5
Join Date: Apr 2010
Location: Austin, TX

iTrader: (0)

Garage List
2007 Z4MCoupe  [0.00]
Thank You for sharing ...this saves me $$.
Appreciate 0
      06-22-2013, 01:30 AM   #10
StickMon
My other car is on Mars
StickMon's Avatar
United_States
19
Rep
1,460
Posts

 
Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (0)

First thing that went out on my car after I bought it used.
I saw the puddle on the driveway and thought "What's that? Oil? Coolant? Wait, this is washer fluid!"
$26.
Appreciate 0
      06-22-2013, 03:22 AM   #11
Vanne
Driver
Vanne's Avatar
United Arab Emirates
11
Rep
860
Posts

 
Drives: 2007 Z4MC
Join Date: Mar 2013
Location: Dubai

iTrader: (0)

yep, both Bimmers i bought used here had this.. loved the fact its bloody cheap to diy.
__________________
2007 EuroSpec Z4///MC DIY Bimmerian Arial. Carma FF Italian race exhaust. BMW Performance 6 Speed Short Shift kit. CDV delete.H&R Springs. Bilstein HD shocks
Appreciate 0
      10-07-2013, 08:39 AM   #12
rmonte4
Private
0
Rep
62
Posts

 
Drives: 2007 BMW Z4 3.0si Roadster
Join Date: Aug 2012
Location: Dallas, TX

iTrader: (1)

Thanks to this thread, this Fix cost me <$8 on ebay.
__________________
2007 Z4 3.0si Roadster
H&R Springs
Plasti-dipped Blueberry

Appreciate 0
      10-07-2013, 07:54 PM   #13
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

Quote:
Originally Posted by rmonte4 View Post
Thanks to this thread, this Fix cost me <$8 on ebay.
__________________
2007 BSM Z4M Coupe - 18" VOLK TE37 - 18" Apex ARC-8 - GC Track/Street
Appreciate 0
      10-18-2013, 08:57 AM   #14
just2talented
Private First Class
just2talented's Avatar
2
Rep
179
Posts

 
Drives: Alpine ///M roadster
Join Date: May 2009
Location: Queens NY

iTrader: (0)

Mine just went, anybody know the part number?
Appreciate 0
      10-18-2013, 12:11 PM   #15
StickMon
My other car is on Mars
StickMon's Avatar
United_States
19
Rep
1,460
Posts

 
Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (0)

Either #4 or #6 here, depending on which one's leaking.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      10-18-2013, 07:51 PM   #16
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

http://www.ebay.com/itm/BMW-3-M-X-Z-...8c9762&vxp=mtr

$6.88 + free shipping.
__________________
2007 BSM Z4M Coupe - 18" VOLK TE37 - 18" Apex ARC-8 - GC Track/Street
Appreciate 0
      10-19-2013, 12:55 AM   #17
StickMon
My other car is on Mars
StickMon's Avatar
United_States
19
Rep
1,460
Posts

 
Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (0)

^WHS

"2,194 sold"

I would classify this as a common problem.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      10-21-2013, 06:16 PM   #18
chickdr
Major
13
Rep
1,358
Posts

 
Drives: 2006 M Roadster
Join Date: May 2009
Location: Atlanta, GA

iTrader: (0)

Mine started leaking a day or so ago. Ordered the new pump but can't find a DIY anywhere. I assume you have to empty the reservoir first? The one leaking for me is the windshield washer pump. Do you just unclip the electrics and pull it out or does the entire reservoir need to come out to do it?
Appreciate 0
      10-21-2013, 07:56 PM   #19
StickMon
My other car is on Mars
StickMon's Avatar
United_States
19
Rep
1,460
Posts

 
Drives: 2006 MR
Join Date: Feb 2011
Location: Lo-Cal

iTrader: (0)

I seem to remember I took the whole thing out so I could dump the juice into a bucket and save it.
Pretty sure there was only 1 bolt holding it on.
If it's already empty, or nearly so, you can skip that step.
The pump just pokes into the grommet/filter.
__________________
Warning: May contain traces of nuts.
Appreciate 0
      10-21-2013, 10:24 PM   #20
KevinC
your average JAMF
KevinC's Avatar
United_States
21
Rep
1,530
Posts

 
Drives: '07 Z4MC, '05 330Ci ZHP
Join Date: Oct 2005
Location: Chandler, AZ

iTrader: (0)

Mine just crapped out, then I stumble into this thread.. amazing. How simple is this thing to swap out? I figure I'll score one of those 3rd world jobs @ $6.88 from Ebay - how wrong can you go at THAT price??
__________________
'05 330Ci ZHP ..PD99819______________'07 Z4M Coupe ..LL93707
Appreciate 0
      10-21-2013, 10:33 PM   #21
i2ichal2dZ4M
Lieutenant
4
Rep
412
Posts

 
Drives: 2007 BSM Z4MC
Join Date: Mar 2011
Location: Los Angeles, California

iTrader: (0)

very easy, id say no instructions even needed.
__________________
2007 BSM Z4M Coupe - 18" VOLK TE37 - 18" Apex ARC-8 - GC Track/Street
Appreciate 0
      10-22-2013, 01:09 AM   #22
Vanne
Driver
Vanne's Avatar
United Arab Emirates
11
Rep
860
Posts

 
Drives: 2007 Z4MC
Join Date: Mar 2013
Location: Dubai

iTrader: (0)

Really? Save the washer water that's in there? Come on, some water and a spot of windex and your done.
__________________
2007 EuroSpec Z4///MC DIY Bimmerian Arial. Carma FF Italian race exhaust. BMW Performance 6 Speed Short Shift kit. CDV delete.H&R Springs. Bilstein HD shocks
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:48 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST