ZPOST
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   ZPOST > BMW Z4 Roadster and Coupe > General BMW Z4 Forum
  TireRack

SUPPORT ZPOST BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER, THANKS!
Post Reply
 
Thread Tools Search this Thread
      06-18-2012, 08:33 PM   #1
KMRDragon
New Member
United_States
0
Rep
8
Posts

 
Drives: 2003 BMW Z4
Join Date: Jun 2012
Location: Utah

iTrader: (0)

SMG Problems

I was driving home today, stopped at a stop sign, and the warning chime went off. I looked at the dash for lights, but none were lit. The transmission shifted into third and wouldn't shift. When I pulled off the road I briefly got a lit automatic trans light (it just flashed once). Immediately the "service engine soon" light came on. I shut the engine off for about three minutes. When I restarted the car the SES light remained on but the trans worked perfectly again. After about 3 stops and starts, the SES light went out. I'm assuming I have an SMG problem of some sort. I'm waiting for the issue to reoccur and leave me stranded somewhere. Anyone? What say you???

2003 Z4 3.0i Sport, 80,000 miles.
SMG trans

Thanks in advance, for any experience anyone could relate
KMR
Appreciate 0
      06-18-2012, 11:31 PM   #2
pokeybritches
Lieutenant Colonel
pokeybritches's Avatar
United_States
20
Rep
1,917
Posts

 
Drives: ESS/G-Power Z4M's, VF Z4 3.0i
Join Date: Sep 2009
Location: Alexandria, VA

iTrader: (10)

Garage List
2006 BMW Z4M  [4.25]
2003 BMW Z4 3.0i  [4.50]
Try and pull the codes. Are you around SLC or Park City? I was just there visiting my gf last weekend lol.
__________________
Appreciate 0
      06-19-2012, 11:49 AM   #3
gferil
Captain
gferil's Avatar
11
Rep
740
Posts

 
Drives: 06 Z4MC
Join Date: Dec 2010
Location: San Francisco, CA

iTrader: (6)

Not too versed in the Z4 SMG, although a Z4 with SMG was the first Z4 I ever drove and what made me fall in love with the car. I wonder though if that SMG has the same "salmon relay" problem as the E46 M3 SMG? Try searching the M3 or E46 forum for that.

On an off topic note...yeah, where in Utah are you? My company is based out of Park City so I go back and forth between SF and PC all the time.
Appreciate 0
      06-19-2012, 03:28 PM   #4
KMRDragon
New Member
United_States
0
Rep
8
Posts

 
Drives: 2003 BMW Z4
Join Date: Jun 2012
Location: Utah

iTrader: (0)

I'm in sandy. SLC suburb, 114 south 20th east, about 25 minutes to Park City. Thanks for the tip, I'll check it out. I suspect relays are the same.
Appreciate 0
      06-23-2012, 12:18 PM   #5
indohan
///MFEST DARK KNIGHT
1
Rep
178
Posts

 
Drives: JDM
Join Date: Feb 2010
Location: Los Angeles, CA

iTrader: (1)

Let me guess, really hot day?
So far only happened once?
You're okay. SMG relay costs less than a nice dinner, you can try doing that first.
__________________
Appreciate 0
      06-23-2012, 04:37 PM   #6
BruceJ
6 of Diamonds (ret)
BruceJ's Avatar
United_States
6
Rep
332
Posts

 
Drives: 07 Z4Si
Join Date: Feb 2010
Location: Georgia

iTrader: (0)

Sorry about your troubles. I looked pretty hard at these on the M-3s. Looked like fun ..... when it works. Previous poster right, start with the relay. 1st law of logical trouble shooting. check/change the simplest/cheapest stuff first. good luck.
__________________

Mods: DaveZ's GDO, DIY Windscreen, Intravee IPOD adapter, MudFlaps, Hardtop Retrofit & Hardtop, Gap-tech Power Top Remote +, M-Front Bumper, Mstache, Diet Hamburgers & a Big Fat Steering wheel, AE's
Appreciate 0
      06-24-2012, 06:04 PM   #7
KMRDragon
New Member
United_States
0
Rep
8
Posts

 
Drives: 2003 BMW Z4
Join Date: Jun 2012
Location: Utah

iTrader: (0)

Yes you are right. I had the relay replaced Friday. It was fine until this afternoon (Sunday). It was hot outside (96). It happened again. Warning chime goes offANSI 5 seconds later It goes into neutral. I guess they replaced the correct relay. Thanks for your comments.
Appreciate 0
      06-24-2012, 06:29 PM   #8
Caddyshk
M = Midlife Crisis
Caddyshk's Avatar
Canada
21
Rep
1,920
Posts

 
Drives: 2006 Z4MC Interlagos
Join Date: May 2007
Location: Oak Ridges, Ontario, Canada

iTrader: (0)

Posted twice?

http://www.zpost.com/forums/showthread.php?t=707422
__________________
2006 Z4MC - #LL93158
SuperSprint Race Cans, RE X Pipe, Fabspeed Headers, OE STB, AS Shifter, Dave Z Modified CDV, Ground Control Coil Overs, Stoptech lines, Hawk DTC Pads, RE Clutch Stop, RE Transmission Mounts, Vibra-Technics Engine Mounts, ZHP Shift Knob, LeatherZ M Shift Boot, Tekarbon Rear Spoiler, CF Grills, Advan RS DGM
Appreciate 0
      06-24-2012, 08:30 PM   #9
indohan
///MFEST DARK KNIGHT
1
Rep
178
Posts

 
Drives: JDM
Join Date: Feb 2010
Location: Los Angeles, CA

iTrader: (1)

If it still happens after replacing the relay, check list in order:

1. check SMG reservoir
2. check battery
3. check alternator
4. check SMG pump.
__________________
Appreciate 0
      06-24-2012, 08:49 PM   #10
Caddyshk
M = Midlife Crisis
Caddyshk's Avatar
Canada
21
Rep
1,920
Posts

 
Drives: 2006 Z4MC Interlagos
Join Date: May 2007
Location: Oak Ridges, Ontario, Canada

iTrader: (0)

He has the SSG unit (Italian controls). Not the Siemens unit from the e46M3's.
__________________
2006 Z4MC - #LL93158
SuperSprint Race Cans, RE X Pipe, Fabspeed Headers, OE STB, AS Shifter, Dave Z Modified CDV, Ground Control Coil Overs, Stoptech lines, Hawk DTC Pads, RE Clutch Stop, RE Transmission Mounts, Vibra-Technics Engine Mounts, ZHP Shift Knob, LeatherZ M Shift Boot, Tekarbon Rear Spoiler, CF Grills, Advan RS DGM
Appreciate 0
      07-09-2012, 04:16 PM   #11
KMRDragon
New Member
United_States
0
Rep
8
Posts

 
Drives: 2003 BMW Z4
Join Date: Jun 2012
Location: Utah

iTrader: (0)

Where is the SMG reservoir located? I can only find the one for brake fluid.
Appreciate 0
Post Reply

Bookmarks

Tags
2003 z4 smg problems, auto trans light, ses light, smg

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:05 PM.




zpost
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST