View Single Post
      11-07-2012, 02:47 PM   #359
kennyfrc
First Lieutenant
 
kennyfrc's Avatar
 
Drives: 2008 Z4MC
Join Date: Aug 2010
Location: ATL GA

Posts: 351
iTrader: (1)

Quote:
Originally Posted by Sal@Evolve View Post
The MSS70 is real slow at adapting.

You will need to run your stock tune way before the dyno.

I think it's time I give a much better insight into this DME to you guys.

This is way more complex than the MSS54 on the E46.

Years ago when we first started working on these cars they baffled us badly.
At the time we were only doing hardware upgrades as there was no reading / writing of the DME's.
What we found back then was the DME would seem to have a complete mind or it's own. One min it's amazing on the dyno. The next (after switching car off), it runs really rich and the top end just drops like a fly.

Years later we started logging and looking at the various VANOS and ignition maps and saw how the DME jumps between them based on various sensor readings and knock count. Even on the best fuel it would do this.

Temperature compensation on these DME's is crazy and you need to really monitor the sensor readings before every run you do. Unfortunately, not everyone has the ability to datalog.
Our developer for the evolve-R is working on data logging for us now and we are trying to get the MSS70 included.

The same thing occurs with the S85 V10 engine. I did a write up a few months back to show M5board members how much temperature has effect on power output on a dyno and showed how to make things far more consistent.

I will give you guys as much info as possible on this topic so you can be aware that just throwing the car on the dyno is not always just what you need to look at.

We spent a lot of time developing this and the independent results have been excellent all over the world and right in line with our dyno dynamics (slightly higher on the dynojets). There is no way or reason that one car will lose power while another will gain. This makes absolutely no sense at all. The tolerances for static cam timing would need to be huge for this to happen and would make one car incredibly poor to drive and idle roughly or to have massive tolerances in the compression which most of you know would cause very poor power to start with.
The usual biggest variable is carbon build up in the combustion chamber but it needs to be a huge amount to cause knock by itself.

The AFR being as rich as it's showing is showing us that either the IAT sensor in the MAF is reading really high because of poor cooling or there is some knock going on BUT the AFR tends to be erratic and even richer if this happens. We simply do not use enough ignition to cause knock. The targets are not high at all on our tunes and especially not stock!

Most of the tuning we do is through VANOS (valve timing).

We really stand by our product on this and it doesn't matter how hard we have to work, there is no way we are letting people down who invested their money in our tune.

If it's a simple small mistake somewhere (very difficult) then we will come clean and explain it in detail by showing you the maps.
Could a simple resistor in the MAF harness eliminate the moving target problem?

Example: 7.6K ohm = 65F reading to the ECU all the time, and keep you in the proper map?
__________________
Toy: 2008 Silver Z4MC 300WHP/241TQ

Mods: OEM Euro Headers, RPI Scoop

Daily: 2010 Tacoma Double Cab
kennyfrc is offline  
0
Reply With Quote